Can't install node-red-contrib-ibm-db2


I am not able to install the node-red-contrib-ibm-db2 nodes. I have an application running in IBM Code Engine in which I need in/out nodes with a db2 database. I have tried to install from the nodered UI and CLI (node-red-admin), but install fails. First part of error in log is as follows:
npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict node-red-contrib-ibm-db2
2023-05-08T17:52:51.315Z [err] npm
2023-05-08T17:52:51.315Z [err] WARN config production Use --omit=dev instead.
2023-05-08T17:53:17.928Z [err] npm ERR!
2023-05-08T17:53:17.928Z [err] code 1
2023-05-08T17:53:17.928Z [err] npm ERR! path /data/node_modules/ibm_db
2023-05-08T17:53:17.929Z [err] npm ERR!
2023-05-08T17:53:17.929Z [err] command failed
2023-05-08T17:53:17.929Z [err] npm ERR! command
2023-05-08T17:53:17.929Z [err] sh -c node installer/driverInstall.js
2023-05-08T17:53:17.930Z [err] npm ERR!
2023-05-08T17:53:17.930Z [err] platform = linux, arch = x64, node.js version = v16.16.0
2023-05-08T17:53:17.930Z [err] npm ERR! make version =GNU Make 4.3
2023-05-08T17:53:17.930Z [err] npm ERR!
2023-05-08T17:53:17.930Z [err] npm
2023-05-08T17:53:17.930Z [err] ERR! ****************************************
2023-05-08T17:53:17.930Z [err] npm ERR!
2023-05-08T17:53:17.930Z [err] You are downloading a package which includes the Node.js module for IBM DB2/Informix. The module is licensed under the Apache License 2.0. The package also includes IBM ODBC and CLI Driver from IBM, which is automatically downloaded as the node module is installed on your system/device. The license agreement to the IBM ODBC and CLI Driver is available in /data/node_modules/ibm_db/installer/clidriver. Check for additional dependencies, which may come with their own license agreement(s). Your use of the components of the package and dependencies constitutes your acceptance of their respective license agreements. If you do not accept the terms of any license agreement(s), then delete the relevant component(s) from your device.
2023-05-08T17:53:17.930Z [err] npm ERR!
2023-05-08T17:53:17.930Z [err] ****************************************
2023-05-08T17:53:17.930Z [err] npm ERR!
2023-05-08T17:53:17.930Z [err] npm ERR! Downloading DB2 ODBC CLI Driver from ...
2023-05-08T17:53:17.930Z [err] npm ERR!
2023-05-08T17:53:17.930Z [err]
2023-05-08T17:53:17.930Z [err] npm ERR!

Do you have any idea what I can do to solve this issue? Are there any dependencies which are not listed?

Welcome to the forum @MariusKolbergsrud

That suggests that it is unable to download that file. Does the system running node-red (not the system running the browser, if they are different) have internet access?
If it does then tell us more about it and how you installed node-red.
If it is a docker install then perhaps the container does not have access to the external network.

[Edit] Do the three dots in the file mean you have missed out the most important part of the log? If so then please post the full log.

Thank you!

I used the nodered/node-red docker image directly in Code Engine. It worked when I used the 1.2.2 version. As I'm quite new to this there are probably better ways to do this. Do you have any tips to "best practice" of publishing a node-red app in Code Engine using docker?

Sorry, I know little about docker and nothing about Code Engine.
I generally advise people to avoid docker unless they have a good reason.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.