Can't load NodeRED after installing alongside HOOBS

Hi, I'm setting up Homebridge for a chum of mine on a RPi 4. Installed HOOBS and they provide a script on their website to run via terminal and installed NodeRED alongside it. I ran that and it went as expected, including confirming installation was successful and that I could access NodeRED via hoobs.local:1880 or :1880.

After rebooting Pi I've tried both methods. Former method just hangs on progress bar and nothing happens. Latter method just tells me that it can't connect to the server. I'm far from being an expert in this but am I missing something obvious here? As a side note, I have my own NodeRED running on it's own Pi 3 without issue. I'm presuming there would be no conflict there? Any help would be greatly appreciated...and in very basic language please!


I don't know hoobs, but I guess the node-red problem is that it has not restarted when you rebooted. So you will need to find how you are supposed to make node-red restart when installed with their script. Do their docs not say anything about that.

To get you going again try going to the .node-red directory (assuming that there is one) and running node-red.

Thanks for the response. The installer script automatically features auto-restart on boot/reboot so I'm not sure that is the issue. If I SSH in to the Pi and type 'ls' nothing comes up at all. I'm at a total loss as to what is going on. Perhaps a fresh wipe/install may be beneficial.

There may be no files other than hidden ones, try ls -al. By default ls will not show files/folders starting with a dot. You should be able to do

cd .node-red

If that ends with an error saying that the port is in use then node-red is already running.
When you had node-red up previously were you running the browser on the pi or another machine?

I tried cd .node-red but that didn't work either. The nodeRED instance I have running on my setup is on a standalone RPi3 and my HOOBS is running on a separate Pi3 to that. I ran the browser on my MacBook.

I know having the two on the same Pi works though as HOOBS offer up this link to set it up as such. Think, as I've only really got the shell of HOOBS and (I thought) NodeRED installed, I'll wipe and re-install both. See if that clears anything. Doing that now so will report back. Thanks again for your assistance.

If there is nothing at all in the home directory then you are problably logged on as the wrong user.
I doubt if re-installing will help. Why do you expect that you will end up with something different?
I think you need someone who knows about hoobs.

I just figured that it may not have installed correctly. Logged in correctly AFAIK. Thanks anyway.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.