Can't open 127.0.0.1:1880 in Browser

Hello everyone!
I've been working on a project for a couple of months now and for two days now I'm unable to open my project in browser.

My Terminal tells me everything is connected but my browser just won't open Node Red.

Has anyone experienced this before?

are you trying to open 127.0.0.1:1880 on the same machine node-red is installed or a remote PC?

127.0.0.1 == localhost

if you are tempting to access the node-red environment on a different PC change 127.0.0.1 to the actual IP of the node-red server.

If it isn't that then exactly what happens when you try to open it in the browser?
Also have a look in the browser Developer Console to see if there are any errors.

I am trying to open 127.0.0.1:1880 on the same machine where node-red is running and I've always done it like that.
my browser just tries to load the site. It's been like this:
Bildschirmfoto 2021-01-16 um 12.55.20

for an hour or so. I also tried with multiple browser and no luck. Can't have a look in browser developer terminal since it can't even load the website

The whole message in Terminal:

Welcome to Node-RED
===================

16 Jan 12:58:03 - [info] Node-RED version: v1.2.7
16 Jan 12:58:03 - [info] Node.js  version: v14.13.0
16 Jan 12:58:03 - [info] Windows_NT 10.0.19041 x64 LE
16 Jan 12:58:04 - [info] Loading palette nodes
16 Jan 12:58:05 - [info] Worldmap version 2.6.0
16 Jan 12:58:05 - [info] Dashboard version 2.23.4 started at /ui
16 Jan 12:58:05 - [info] Settings file  : \Users\Saskia\.node-red\settings.js
16 Jan 12:58:05 - [info] Context store  : 'default' [module=memory]
16 Jan 12:58:05 - [info] User directory : \Users\Saskia\.node-red
16 Jan 12:58:05 - [warn] Projects disabled : editorTheme.projects.enabled=false
16 Jan 12:58:05 - [info] Flows file     : \Users\Saskia\.node-red\flows_LAPTOP-J60STHNJ.json
16 Jan 12:58:05 - [info] Server now running at http://127.0.0.1:1880/
16 Jan 12:58:05 - [warn]

---------------------------------------------------------------------
Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.

You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.
---------------------------------------------------------------------

16 Jan 12:58:05 - [info] Starting flows
16 Jan 12:58:06 - [info] [ui_worldmap:50e925f4.23c04c] started at /worldmap
16 Jan 12:58:06 - [info] [ui_worldmap:new] started at /newmap
16 Jan 12:58:06 - [warn] [telegram command:Mistkuebel start] bot not initialized.
16 Jan 12:58:06 - [warn] [telegram command:Mistkuebel getupdates] bot not initialized.
16 Jan 12:58:06 - [warn] [telegram sender:c9e943d3.65f3a] bot not initialized.
16 Jan 12:58:06 - [warn] [telegram command:Mistkuebel start] bot not initialized.
16 Jan 12:58:06 - [warn] [telegram command:Mistkuebel getupdates] bot not initialized.
16 Jan 12:58:06 - [warn] [telegram command:Mistkuebel erstelleMistkübel] bot not initialized.
16 Jan 12:58:06 - [warn] [telegram sender:bb969782.90a878] bot not initialized.
16 Jan 12:58:06 - [info] Started flows

You haven't specified the port number in the url.

yeah I have, Safari just won't show it but when I click on the url Safari will show the full url

In that case try localhost:1880 and if that also doesn't work then I suspect node-red may be stuck in a loop of some sort. Stop node red then start it again using
node-red --safe
which will start the editor without starting the flows.
If that does it then what were you doing when it stopped working? Something with MQTT possibly, or feeding values back into the front of dashboard switches or something similar.

Edit Also I asked what you see in the developer console.

I tried localhost earlier - no difference

It is actually starting with node-red --safe and it will deploy but not do anything...
but it will freeze as soon as I try to open the dashboard.

I'm not 100% what I did before it stopped working, but yes my application uses MQTT and the dashboard

It is quite possible in your last modification (or a bug in your flows has surfaced) that has caused a loop & preventing transmissions occurring due to being bogged down. Try start in safe mode again and disabling (temporarily) anything that looks like a loop or an MQTT out node, then work from there.

MQTT loops can be harder to find but in basic terms, if you subscribe to a topic that you later update & send to mqttout node, you can create an infinite loop.

Open another MQTT client, such as mosquitto_sub or MQTT Explorer, subscribe to "#" and see if something is clobbering it.

That confuses me slightly, I understood it was the editor that was hanging, not the dashboard. If you deploy are you able to carry on editing flows in the editor?