Can't see device-monitor node after install in Node Red

I have installed the following node into my working NR server (v3.1.3) via Palette -> Install, but it doesn't show up in the list of available nodes ot use in workflow. Restarted NR and the host server, refreshed browser, still not there. Any ideas why not?

Search available node yields no result:

Aslo tried running this in the .NodeRed folder, but still doesn't appear:

sudo npm install node-red-contrib-device-monitor

Welcome to the forum @efelmer

What hardware/OS are you using?

Do you see anything in the browser developer console if you refresh the page?

If not then show us what you see if you restart node-red in a command window. It should start with the Welcome to Node-red message.

It appears that the node does not work any more.

It is always worth checking for issues on a node's github page if you have problems.

Hi Colin,

Raspberry Pi 4B:
PRETTY_NAME="Raspbian GNU/Linux 12 (bookworm)"
NAME="Raspbian GNU/Linux"

Nothing obviously failing in console on page refresh.

Ah, I had a look on NPM site and github, but missed the issue. As they say in the UK advert, should have gone to Specsavers :wink: Thx Colin.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.