Connecting influxdb node to influx database with version 1.8

I've installed node red (version 1.8.10) and influxdb 1.8 on my raspberry pi. I've setup a database called influx. On the visual interface of node red, I can easliy connect to the influx database when I select option 1.x. But if I try to select version 1.8, it gives me the following error: {"error":"database not found: "database""}.

Have you tried deleting the config, and creating a new one set to 1.8flux ?

Im using InfluxDb 1.8 on docker and running the 1.x setting in the node config

works fine for me.. you have to be carefull as database and measurement settings are CASEsensitive

Do you mean you are selecting 1.8flux? Don't do that unless you want to use the flux query language. If you want to use the normal SQL type query language then you should use 1.x, which means any version 1 including 1.8

It works fine when selecting "1.x" as the version. However I want to select the version 1.8flux in order to use the flux query language. The error comes when I select 1.8flux as the version.

Correct, I want to use 1.8flux in order to use the flux query language. It seems to have more flexibility.

Show us how you have configured the influx node and the server node.
You can paste an image in here.

This configuration with version 1.x works

However, when I select 1.8, like this

it starts giving the following error,

I've tried adding the name of my database in the url like,
http://localhost:8068/influx, but it does not work.

What query have you specified for the 1.8flux in node?

This is the simple query I have at the moment

I haven't seen set used in from, where did you get that from? I use
where database_name is the database name and retention_period is the retention period, obviously.

I've changed as per below:

however, I see the following message:

but I've done the appropriate changes in the config file, and also added a self-certified key.

this is my section http of my config file

Please don't post images when you could paste the text, as it prevents me from copying out of it.
You need to remove the # characters on the lines you have changed. The # makes the line a comment which has no effect. The values are there to show you the defaults.

Oups ... I've removed the #'s but it messes up everything ... my Grafana and my nodered dashboards stopped working. It may just be better to stick with version 1.x for now.

I've setup my rpi on 64bit, installed influxdb v2 on a docker compose configuration. Definitely works better, after a bit of a learning curve on the flux language.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.