Cursor in wrong position

Good day

I am new to Node Red, I have only been playing around for the past month or so.
I have a Raspberry Pi 3 setup with Node Red installed on it with the following Nodes installed:

I have this setup to connect to my Alexa to control a automated part storage project I am working on with telegram and Homekit for some lights in the house. I have a func node that is for the Telegram keyboard which worked perfect for the entire period that I had it running(+-month), when all of a sudden when I wanted to expand the keyboard options for Telegram my cursor seems to be in the wrong place. I woud click at the end of the sentence and my cursor would be between 2 and 4 characters left, when I type the computer types where I have clicked but my cursor still show on the incorrect space. I have tried this on my Windows work computer and the problem is not visible as well as my iPad without a issue, it only occurs on my Macbook 2012 13". I have tried to reinstall everything on the Raspberry Pi, tried to reboot in safe boot which seems to make no difference at all. Pictures attached where the cursor should be at the end but shows between s and g of return msg.

Any advice or recommendation?

Screen Shot 2020-05-24 at 23.19.00

Which browser on the Mac are you using and have you tried a different browser?

I used Safari when testing out. Few hours ago I tried Google Chrome on the Macbook and it works on Chrome but not Safari. It seems to be Safari issue then, don't know how to fix it or what could cause it in Safari.

So don't use safari :slight_smile:

It might just be a safari issue. All you could possibly do is report the issue to Apple.

Or it could be a font rendering problem similar to one mentioned recently about missing underline characters

Seems to be limited to Safari on the Macbook, Safari on the iPad is okay. Will post on Apple website and see if they have a solution. There was a MacOS update a a couple of days ago, could have been where the problem originated. Thanks

Oh yeah - good call. I wonder?

OP could try the fixes described in this thread - see if it helps?

I doubt this would have anything to do with that Issue...

Found the solution. My safari was zoomed in to 125% causing the problem. Zoomed out and works like a dream.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.