Can't see my underline char

I've got an _ between "incoming" and "phrase" but I can't see it in the function editor

Just me?

[edit]Just checking as this is from a VNC session[/edit]


mmm - seems to be a VNC issue as its fine when I look at it natively from my Win10 Machine Chrome

[edit2] or it could be a Pi Chromium issue as I use a Pi4 for all my NR editing and VNC into the Pi4- has someone got a Pi4 hooked up direct to monitor and could check if its Chromium or VNC?[/edit2]

Just a question.

Why do you vnc to the pi instead of accessing the node-red instances from your pc browser?

Just curious.

I found that with 8 open Node-RED instances, my main machine memory was being eaten up by the browser tabs and eventually machine starts swapping out to hard disc (with all the other stuff I have running as well) so I just put my mainly unused Pi4 to good use to act as my Node-RED central command

Just sits there using 33% CPU and at 55deg C - Great the Pi4 overheating prob got sorted :slight_smile:

1 Like

I understand. Have you tried Firefox on the raspberry? will be interesting to see if it's vnc that's causing this or Chromium.

Might be worth editing the title to ask people with the raspberry pi 4 to chip in.

No - usually (from what I've seen in posts over the years) trying other browsers is a painful/unproductive method :slight_smile:
But I'll google and see if its currently working on a Pi4 :slight_smile:

Pretty typical of the posts I've seen over the years :slight_smile:

Yeah haha. But I was certain on raspian (assumption made right there) that FF was installed by default (it's been a while since I touched one)

I've decided not to waste 2 hours trying to install it :slight_smile:

I'll wait till someone who uses browser on a Pi4 (or any Pi) connected to a monitor to come back first :slight_smile:

I'm a noggin - I'd already had it installed!

But didn't help me

[edit]Tried again - same result[/edit]

Did I mention?


Common issue I’ve seen this many times over the years. Always at the underscore character. Applications that use GTK underneath anywhere seem to have this even more.

1 Like

Just tried Midori browser - VERY slow but it shows the _ so its a Chromium browser issue :slight_smile:

I think people have reported it before and changing the zoo to 90% or 110% may also make it reappear.

1 Like

A quick look (out of interest) see this going back to 2010.

Seems to be a font issue (which coincides with what dave said).

I didnt read it all to see if there was a nice easy fix (like changing font) - but take a look if you feel inclined.

1 Like

I have exactly the behaviour Dave described. Zoom to 110 or 90% makes them visible. I thought it was a quirk of my dark theme!

1 Like

Whenever I run into this problem (had this a lot when in university and having to write mssql queries with long prefixes full of underscores) I turn on the search in whatever application I’m in to highlight underscores that way. A workaround at best.
Fonts/zoom make sense. It also happens when you run GTK based applications on Windows, try it out with Geany Text Editor :stuck_out_tongue:

Changing Chromium browser zoom to 90% works :slight_smile:

Minor issue @dceejay
Zooming to 90% sorted out underline but I've noticed that this part of the dialog hasn't scaled well
Obviously not important but maybe it should so just reporting it as maybe there is a little bug in its code somewhere

I realised yesterday that I have the same underscore issue on my Linux Mint laptop's Chrome. Super annoying! 90% is too small, 110% is huge. :unamused:

Might try if for example tweaking the line height in CSS would fix it.

@ristomatti if possible during your testing, see if a different font fixes it (roboto monospace?).

Hopefully you find a nice easy fix that can be baked into node-red core to fix this for everyone.

Changing the font would not be a solution for me. But luckily CSS did the trick at least in my case:

/* Fix hidden underscore on some systems */
.ace_editor .ace_content {
    line-height: 1;

@cymplecy if you want to try if this helps, you can add those lines to editor-underscore-fix.css inside your .node-red folder. Then add the file as a custom editor theme in settings.js editorTheme section just before the closing bracket:

    editorTheme: {
        page: {
            css: [