Graphical abnormalities when using local Raspberry Pi such as missing wires

I always use a remote machine to manage my Node Red that lives on a Raspberry Pi 4. This is what one of the flows on this tab should look like:

This is what the same flow looks like if I open Node Red on the local machine. The wires are gone and there is some illegible "garbage" at the top left corner (I highlighted it):

There should be 5 additional flows on this tab but they do not appear. The wires are missing on some other tabs although the "garbage" doesn't appea. However, I have some tabs that appear correct with the wires then I have this disaster:

Does anyone have any suggestions? It would seem to be something wrong with the Raspberry Pi being able to handle the graphics vs something wrong w/ my Node Red flows. It happens when opening using Chrome and Firefox browsers.

Had similar issues but in windows environment using google chrome. if you go through the thread may be it will lead you to something.

1 Like

it looks like the issue is that I am using Chromium 92. Supposedly there is a new version(s) but my RPi is telling me my install is up-to-date. It wouldn't matter except that it seems that the newest version of the Dropbox Node pallet needs to be setup initially from the host machine in order to do initial authorization.

Are you sure? If you run
sudo apt update
then
sudo apt policy chromium
what do you see?

What makes you think that? I don't have a display on my PIs at all, so that would mean I would not be able to use that node.

Hi @stephenn

What version of Node-RED are you using?

Can you also check the browsers developer console for any error messages?

I don't know what information the policy command provides; i just see that the previous says that chromium-browser 92.0.4515 is already installed on machine.

If the node was working correctly, then I would be fine using this Node Red node headless. However, in doing troubleshooting on the node, I needed to use localhost URL so I need to use Node Red using a browser on the Raspberry Pi

How did you do that. I have tried and just bump into a brick wall. The info I have found says you either have to have a domain or a browser on the Pi.?

I run a few pi's headless and use VNC. Usually I set up the pi's headless as well. It involves a few tweaks to the pi's config file and then ssh to setup VNC.

How did I do what? Run node-red headless? Or do you mean how do I use Dropbox, to which the answer is I don't. In fact I see you are right about needing to run the browser locally for this. The problem is under active discussion in this thread, I think.

Yes, I am actually the one that instigated that thread by some posts on Github discussion about the problem that I was having with new version of Dropbox pallet. :grin:

@stephenn can you answer the questions I asked here : Graphical abnormalities when using local Raspberry Pi such as missing wires - #5 by knolleary

Without that, it'll be hard to know exactly what is happening here.

I updated to Node Red 3.0.2 about 48 hours ago. I just opened my flows and they all appear normal. However, the flows were graphically messed up yesterday after I updated. No idea why it's working now.

Probably the browser cache had been flushed by the restart.