Custom node changes in dev folder not loaded

Quick question :
On all my other window machines the changes I make in the dev folder which is linked to my github get picked up after doing npm install node-name

On 1 machine that doesnt happen for some reason...

actions tried :slight_smile: uninstall node red completely, uninstalled custom modules.

Does somebody know what to check so I can link the folders ?

more specifics :
dev folder is on my c drive.
node red is in the default location on windows.

You need to npm install place/where/cloned/source/is

Then any changes in place/where/cloned/source/is are picked up when you restart node-red.

yes as I have done on all the other machines. Only for this particular installation / machine it doesnt seem to pick up the changes whenever I change the clone source file.
Even after complete re-install.

If you actually did that :point_up: then it wont work.

As I said, you need to do npm install place/where/cloned/source/is NOT npm install nodename - and that needs to be done in the .node-red dir.

This creates a symlink to the source directory - which is super easy to check...

  1. look in .node-red/packge.json - what do you see for your node in the dependencies?
  2. if you create a new file in the your-node/source directory, do you see that appear in .node-red/node_modules/your-node/?

Hey steve,

Yes I have done what you wrote (so not what I wrote exactly) I referenced the location where the source is stored.

content of the package.json (since its new it only contains the one file)

    "name": "node-red-project",
    "description": "A Node-RED Project",
    "version": "0.0.1",
    "private": true,
    "dependencies": {
        "pump": "file:../../../typicals/node-red-contrib-pump"

the weird thing is the node itself on my c drive is named differently I have installed it with the specific command :
npm install c:/.....sourcefolder/node-red-contrib-pump

However in the modules folder of node red there the folder only is named pump , not node-red-contrib-pump

As for your second question - > no I dont see anything happening in the node red folder for what I do in the source folder.

It sounds like it is wrongly linked.

Delete the dependency from package, run npm install with full path using fwd slashes starting from c:/ e.g. c:/path/to/src

And make sure you are in the .node-red folder when you run the npm install command.

Hey both,

I have on all machines exactly the same... Its still not linked.

The problem persists in the fact that Im using the source to insall but whenever there is a change to it it doesnt seem to update the clone.

Wait is this something that is done sepperatly? and could it persist after removal of node red? If that is the case how to remove dependency ? I have tried " npm remove /.../node-red-contrib-etc...

Yes, uninstalling node-red is completely unwarranted and unnecessary.

Uninstalling node-red removes the node-red runtime/application - it does NOT touch your .node_red directory. so anything that was there - will still be there.

just delete the line from package.json & save it

PS: I recommend you actually just delete the entire .node-red/node_modules directory and run npm install from inside .node-red to get a fresh set of modules from npm.

followed by installation as described

Tried it all didnt work as intended... something tells me that npm is responsible for this mess but ill have a complete removal and reinstall of that 2.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.