Daemon.log increasing constantly

hello, i have nodered 2.1.4 installed on my RPI 3 (buster) and i'm using google home contrib:

i see my daemon.log populated like below:


Jan 10 11:56:41 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 41.213 ms - 1744#033[0m
Jan 10 11:56:45 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 30.245 ms - 1744#033[0m
Jan 10 11:56:48 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 43.166 ms - 1744#033[0m
Jan 10 11:57:40 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 39.003 ms - 1744#033[0m
Jan 10 11:57:45 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 46.460 ms - 1744#033[0m
Jan 10 11:57:48 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 42.826 ms - 1744#033[0m
Jan 10 11:58:40 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 31.265 ms - 1744#033[0m
Jan 10 11:58:45 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 41.048 ms - 1744#033[0m
Jan 10 11:58:48 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 26.223 ms - 1744#033[0m
Jan 10 11:59:40 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 43.270 ms - 1744#033[0m
Jan 10 11:59:45 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 58.807 ms - 1744#033[0m
Jan 10 11:59:48 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 29.852 ms - 1744#033[0m
Jan 10 12:00:40 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 24.470 ms - 1744#033[0m
Jan 10 12:00:45 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 49.706 ms - 1744#033[0m
Jan 10 12:00:48 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 31.873 ms - 1744#033[0m
Jan 10 12:01:41 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 50.504 ms - 1744#033[0m
Jan 10 12:01:45 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 34.934 ms - 1744#033[0m
Jan 10 12:01:48 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 57.764 ms - 1744#033[0m
Jan 10 12:02:40 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 21.086 ms - 1744#033[0m
Jan 10 12:02:45 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 61.691 ms - 1744#033[0m
Jan 10 12:02:48 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 37.013 ms - 1744#033[0m
Jan 10 12:03:40 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 51.213 ms - 1744#033[0m
Jan 10 12:03:45 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 65.442 ms - 1744#033[0m
Jan 10 12:03:48 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 26.467 ms - 1744#033[0m
Jan 10 12:04:40 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 32.130 ms - 1744#033[0m
Jan 10 12:04:45 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 45.174 ms - 1744#033[0m
Jan 10 12:04:48 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 44.380 ms - 1744#033[0m
Jan 10 12:05:45 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 35.365 ms - 1744#033[0m
Jan 10 12:05:48 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 35.311 ms - 1744#033[0m
Jan 10 12:06:45 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 49.188 ms - 1744#033[0m
Jan 10 12:06:48 raspberrypi Node-RED[317]: #033[0mPOST /smarthome #033[32m200#033[0m 26.210 ms - 1744#033[0m

of course i disable all my debug nodes and also node.warn inside my functions.

there is a way to avoid of saving logs in daemong.log ??
also syslog is in same situation
and i also notice that if i activate a debug node or a node.warn the outout of this two is written on daemon.log and syslog and i don't need that :slight_smile:

Do you have Enable Node Debug ticked in the google-smarthome Management node?
Also, is your smarthome node up to date? most logging was disabled a few versions ago.

smarty

thanks @Paul-Reed

Do you have Enable Node Debug ticked in the google-smarthome Management node?

no it is disabled (i think you are referring to managment node)

Also, is your smarthome node up to date? most logging was disabled a few versions ago.

mine node-red-contrib-google-smarthome is 0.3.9

The OP has now raised a git issue, see daemon.log growing faster · Issue #364 · mikejac/node-red-contrib-google-smarthome · GitHub

@Paul-Reed thanks, let's see there if there will be a fix.

in the mean time, as general question, there is a way to allow nodered to save message log on daemon.log and syslog?
because i see that when i develop a code and i use node.warn or debug node, the information are saved in daemong.log and syslog.
there is a way to avoid that?
thanks