Troubleshooting problems with node-red-contrib-google-smarthome

Hi folks,

I had hoped to have the node-red-contrib-google-smarthome up and running during my holidays. But in about 10 minutes I'm off to bed, and then my holidays are over and out. So mission failed :roll_eyes:

In a previous discussion I succeeded in making port 3001 public available. I had hoped that things would go smoother now. But as soon as I enter a "Talk to my xxxApp" in the Actions Console Similator, things go immediately horrible wrong again:

Since I had to enter a large amount of settings to get to this point, I have no clue at all what could be wrong...

It would be nice if I had a series of checks to test every individual step in this process. Like e.g. the check in the previous discussion was very useful to pinpoint where the problem was located...

Thanks !!!!

BTW I have activated the logging in the config node. But I only get logs (via node-red-log) for the https://<my_wan_ip>:3001/check, but no extra log lines when I do the test in the simulator:


So not sure if the simulator has send anything to my service that is listening to port 3001 ...

Have you tried using Google assistant instead of the simulator, as the error message suggests.

I'm away from home until Saturday evening, but when I get back, we can compare setups/tests/results if that helps.

1 Like

Thanks!!! Will try that tonight.
That is indeed a good end-to-end test. But if you (or anybody else) has ideas to do intermediate tests, that would be nice: e.g. check my token or whatever... That would allow me to find more easily where I did something wrong.

Nothing urgent. It is my wife's birthday tomorrow so no Node-RED for then ...

It seems that there is Google Cloud Logging, where the action logs are stored. Those logs can be viewed via the Google Cloud Console, under the Log Explorer menu item. After specifying the correct time window, I can see the logs of that moment:

A quick view shows "SYNC: Request ID 18364422339424854821 failed with code: OPEN_AUTH_FAILURE", so I assume it will be related to OAuth2...
Will need to have a look at those logs in more detail during the next days.
Hopefully there are some understandable errors that give me the golden tip ...

using the Google assistant app it immediately worked :champagne: :clinking_glasses:
Thanks a LOT for helping me!!
I was so focussed on the technical part, that I didn't read the info text well ...

What I don't really understand: I thought that I had to say first "Talk to my xxxApp".
However, when I say "Hey Google, put my christmas tree on" that also works ...
So not sure why that "Talk to ..." is required.

Did I miss some months? :smiley:

1 Like

It's probably one of Bart's unfinished projects from Christmas 2018 :laughing::laughing:


I had added a christmas tree node at the time being, but at that moment I couldn't get the google-smarthome running. So my main target was to control that node (kerstboom=christmas tree):


Note that the output of this node is not connected to anything, because I have no physical christmas tree available in the living room at the moment :wink:

Nearly correct. It was 2019 to be correct :sunglasses:

1 Like

You could always create a Christmas tree out of ui-led nodes….

Don't forget my world famous SVG christmas tree...

1 Like

(Head slap) how could anyone forget! Now you have a tree to light up!!!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.