Dashboard Chart not working

Hello. First time user here, so please bare with me. I am following a network monitoring tutorial for Raspberry Pi and was excited to try out Node-Red. I'm running the latest Buster version of the OS (just re-imaged yesterday) and on this clean install I used the Install Script to install node-red. I also added via npm node-red-dashboards, node-red-snmp and otheres.

I was able to create my first node-red flow, which is a simple ping monitor feeding into dashboards chart.

But when I deploy the flow and then browse to http://{{ip address}}:1880/ui, my chart shows up as being blank. I can see the header title of my group and the chart beneath it... but there's no chart at all. Not even an blank/empty chart.

Also the "home" button at the top is non-clickable, in fact nothing on the /ui page is clickable. So I'm starting to think there must be some other package I need to install. It looks like the UI/Dashboards function isn't working right.

I know there isn't much to go off here troubleshooting wise, I can look at any log file or other config files as necessary. Very curious to see what I have done wrong.


You need to send it some data .

Hi and welcome.

Ok, what you need to do is export the flow and paste it here so people can see it.

This is done by going to the edit screen and drag selecting the nodes then up in the top right corner of the NODE-RED window click the menu button. (Aka "the hamburger" is that is what it kind of looks like.)

Select EXPORT copy to clipboard and ok.

Reply and click the </> button at the top of the edit screen and paste the code.

Maybe a screen shot too would help.

1 Like

Thanks for the swift reply. Here is the export

[{"id":"c53b340f.9b3d38","type":"ui_chart","z":"9083359e.e91dd8","name":"Router Ping","group":"52bf2184.2f0fe","order":0,"width":"6","height":"3","label":"Router Ping","chartType":"line","legend":"false","xformat":"HH:mm:ss","interpolate":"linear","nodata":"No Data","dot":true,"ymin":"1","ymax":"50","removeOlder":1,"removeOlderPoints":"","removeOlderUnit":"86400","cutout":0,"useOneColor":false,"useUTC":false,"colors":["#1f77b4","#aec7e8","#ff7f0e","#2ca02c","#98df8a","#d62728","#ff9896","#9467bd","#c5b0d5"],"outputs":1,"x":500,"y":220,"wires":[[]]},{"id":"5346bc2.2526a44","type":"ping","z":"9083359e.e91dd8","mode":"timed","name":"ROUTERPING","host":"","timer":"20","inputs":0,"x":240,"y":220,"wires":[["c53b340f.9b3d38"]]},{"id":"52bf2184.2f0fe","type":"ui_group","name":"Ping Chart","tab":"24322cac.39b734","order":1,"disp":true,"width":"6","collapse":false},{"id":"24322cac.39b734","type":"ui_tab","name":"Home","icon":"dashboard","disabled":false,"hidden":false}]

Here is a screen grab of what I see when I browse to /ui


I figured something out. I clearly have no idea what I am doing, but in the chart properties I tried changing it from the home tab to a different tab name, and suddenly I've got a chart displaying data on the ui.

Very odd.. but i'll take it.

Hi again.

If you are posting flows with foreign nodes, please give the people a head's up.

I just tried to import it and got...... missing nodes.

How about you take this to the nuts and bolts level.

Get an inject node, get the chart node stick the random node between them and set it to do random 1 - 10.

I'm not sure that comes as standard, but if you have got other foreign nodes installed, it would not be too hard to get that one node and do this.

Set the chart accordingly.

Press the inject node and see what happens.

Then, with that you can put debug nodes on your flow's "input" from the ping stuff and see if it is ok to give to the chart.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.