Dashboard not Appearing in Drop-down menu


After npm installing node-red-dashboard (I made sure to "npm init" the directory my dependencies were going into first) I rebooted my instance and the dashboard didn't appear in the dropdown menu below the main menu on the top right.

I also tried rebooting the device but it still wouldn't appear.

I'm having the same problem with the camerapi contrib I attempted to install via npm (near bottom left):

Advice or suggestions welcome.

Are you talking about the dashboard or the editor menu? An image and/or your flow and a better description would be helpful to understand your issue

Have you restarted node-red after installing?

Have you refreshed browser?

What path is node red installed and what path did you run npm install?

I have restarted node-red after installing.
I've refreshed the browser.

Node red is installed at /home/pi/.node-red, and I tried running npm installs for both package collections at /home/pi/.node-red and /home/pi.

These are the contents of my package.json file in /home/pi/.node-red:
"name": "node-red-project",
"description": "A Node-RED Project",
"version": "0.0.1",
"dependencies": {
"node-red-contrib-camerapi": "0.0.38",
"node-red-dashboard": "^2.15.4"

Correct location to install is from /home/pi/.node-red

Check inside /home/pi/.node-red/node_modules. Look for node-red-dashboard (I think)

Another thing to try, edit /home/pi/.node-red/settings.js - increase logging to debug. Restart node-red, capture the log and paste here.

"node-red-dashboard" and "node-red-contrib-camerapi" are both full directories in the /home/pi/.node-red folder.

I haven't been able to find how to access the node-red logs, or where they are stored.

In a terminal run


and post what you get. You should see a Welcome to node-red message followed by the startup log. Copy/paste the text if possible rather than a screenshot.

Rebooting my machine did it.
13 Jun 21:11:06 - [metric] {"level":99,"event":"runtime.memory.rss","value":61960192,"timestamp":1560460266945}
13 Jun 21:11:06 - [metric] {"level":99,"event":"runtime.memory.heapTotal","value":30535680,"timestamp":1560460266946}
13 Jun 21:11:06 - [metric] {"level":99,"event":"runtime.memory.heapUsed","value":25956272,"timestamp":1560460266946}
13 Jun 21:11:21 - [metric] {"level":99,"event":"runtime.memory.rss","value":61800448,"timestamp":1560460281946}
13 Jun 21:11:21 - [metric] {"level":99,"event":"runtime.memory.heapTotal","value":30535680,"timestamp":1560460281947}
13 Jun 21:11:21 - [metric] {"level":99,"event":"runtime.memory.heapUsed","value":25963408,"timestamp":1560460281947}
13 Jun 21:11:36 - [metric] {"level":99,"event":"runtime.memory.rss","value":61386752,"timestamp":1560460296964}
13 Jun 21:11:36 - [metric] {"level":99,"event":"runtime.memory.heapTotal","value":27389952,"timestamp":1560460296966}
13 Jun 21:11:36 - [metric] {"level":99,"event":"runtime.memory.heapUsed","value":23105172,"timestamp":1560460296968}
node-re13 Jun 21:11:51 - [metric] {"level":99,"event":"runtime.memory.rss","value":61386752,"timestamp":1560460311999}
13 Jun 21:11:52 - [metric] {"level":99,"event":"runtime.memory.heapTotal","value":27389952,"timestamp":1560460311999}
13 Jun 21:11:52 - [metric] {"level":99,"event":"runtime.memory.heapUsed","value":23112900,"timestamp":1560460312000}
d stop
node-red start
13 Jun 21:12:07 - [metric] {"level":99,"event":"runtime.memory.rss","value":61386752,"timestamp":1560460327076}
13 Jun 21:12:07 - [metric] {"level":99,"event":"runtime.memory.heapTotal","value":27389952,"timestamp":1560460327077}
13 Jun 21:12:07 - [metric] {"level":99,"event":"runtime.memory.heapUsed","value":23118116,"timestamp":1560460327078}

Now after I reboot it again (in different ways and a few times), everything shows up.

Thanks for your patience!