Dashboard not appearing

#1

Hi
Today I used node red with raspberry pi3 and after installing the node red and start with blinking led project I moved to ip:1880/ui but there were nothing to appear on it

Please advice

0 Likes

#2

Did you create a flow using dashboard nodes?

0 Likes

#3

Yes
I follow this video


But no switches appear to play with it
0 Likes

#4

If you are in Node-RED and you go to the menu ( top right ) and click
What version does it say you are using? ( bottom of menu)

If there is a β€œManage palette” option on that list, click on it, on the page that comes up, where it says β€œfilter nodes”
if you type in β€œdashboard” does it find the nodes?

0 Likes

#5

Hi
please see the screen shot
e4
also please see the node red at starting if I miss somthing since i'm very new on the node red just today I start with :slight_smile:
8 Jun 21:23:22 - [info] Node-RED version: v0.15.3
8 Jun 21:23:22 - [info] Node.js version: v0.10.29
8 Jun 21:23:22 - [info] Linux 4.4.50-v7+ arm LE
8 Jun 21:23:25 - [info] Loading palette nodes
pi : TTY=unknown ; PWD=/home/pi ; USER=root ; COMMAND=/usr/bin/python -u /usr/lib/node_modules/node-red/nodes/core/hardware/nrgpio.py info
pam_unix(sudo:session): session opened for user root by (uid=0)
pam_unix(sudo:session): session closed for user root
8 Jun 21:23:34 - [info] Dashboard version 2.9.4 started at /ui
8 Jun 21:23:41 - [info] Settings file : /home/pi/.node-red/settings.js
8 Jun 21:23:41 - [info] User directory : /home/pi/.node-red
8 Jun 21:23:41 - [info] Flows file : /home/pi/.node-red/flows_pi.json
8 Jun 21:23:41 - [info] Starting flows
8 Jun 21:23:42 - [info] Started flows
pi : TTY=unknown ; PWD=/home/pi ; USER=root ; COMMAND=/usr/bin/python -u /usr/lib/node_modules/node-red/nodes/core/hardware/nrgpio.py out 40
pam_unix(sudo:session): session opened for user root by (uid=0)
8 Jun 21:23:42 - [info] Server now running at http://127.0.0.1:1880/

0 Likes

#6

0 Likes

#7

Ahh you are using an old version of Node-RED and node.js.

You can follow the instructions here to upgrade https://nodered.org/docs/hardware/raspberrypi

Once you’ve done that try again

0 Likes

#8

Hi
i follow the link and still not able to see the final dashboard IP:1880/ui as screenshot


I got on screen ((Cannot GET /ui/))

please advise

0 Likes

#9

Have you got any other β€œdashboard” nodes installed?

What is the flow you are using with a dashboard node in?

Can you repost the startup log details now you have upgraded.

0 Likes

#10

Hi
I hope the text below can has your two questions since i’m new in node red i may not understand these questions
Start Node-RED

Once Node-RED has started, point a browser at http://192.168.0.109:1880
On Pi Node-RED works better with the Firefox or Chrome browser

Use node-red-stop to stop Node-RED
Use node-red-start to start Node-RED again
Use node-red-log to view the recent log output
Use sudo systemctl enable nodered.service to autostart Node-RED at every boot
Use sudo systemctl disable nodered.service to disable autostart on boot

To find more nodes and example flows - go to http://flows.nodered.org

Starting as a systemd service.
9 Jun 13:08:19 - [info] Started flows

0 Likes

#11

There should be more in the log than that. Use the command

node-red-log

to see it. Ctrl+C will get you out of the log.

0 Likes

#12

Also from the command line go to the node-red folder:
cd .node-red
then enter:
npm list -depth=1

and post the result of all the lines starting with β€˜node-red-’

0 Likes

#13

Welcome to Node-RED

9 Jun 13:52:49 - [info] Node-RED version: v0.18.7
9 Jun 13:52:49 - [info] Node.js version: v8.11.2
9 Jun 13:52:49 - [info] Linux 4.14.34-v7+ arm LE
9 Jun 13:52:53 - [info] Loading palette nodes
9 Jun 13:53:04 - [info] mDashboard version 0.1.5 started at /mui
9 Jun 13:53:18 - [info] Settings file : /home/pi/.node-red/settings.js
9 Jun 13:53:18 - [info] User directory : /home/pi/.node-red
9 Jun 13:53:18 - [warn] Projects disabled : editorTheme.projects.enabled=false
9 Jun 13:53:18 - [info] Flows file : /home/pi/.node-red/flows_pi.json
9 Jun 13:53:18 - [warn]

Your flow credentials file is encrypted using a system-generated key.
If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.
You should set your own key using the β€˜credentialSecret’ option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

9 Jun 13:53:19 - [info] Starting flows
9 Jun 13:53:19 - [info] Started flows
9 Jun 13:53:19 - [info] Server now running at http://127.0.0.1:1880/

0 Likes

#14

pi@pi:~ cd .node-red pi@pi:~/.node-red npm list -depth=1
node-red-project@0.0.1 /home/pi/.node-red
β”œβ”€β”¬ node-red@0.18.7
β”‚ β”œβ”€β”€ basic-auth@2.0.0
β”‚ β”œβ”€β”€ bcrypt@1.0.3
β”‚ β”œβ”€β”€ bcryptjs@2.4.3
β”‚ β”œβ”€β”€ body-parser@1.18.3
β”‚ β”œβ”€β”€ cheerio@0.22.0
β”‚ β”œβ”€β”€ clone@2.1.1
β”‚ β”œβ”€β”€ cookie@0.3.1
β”‚ β”œβ”€β”€ cookie-parser@1.4.3
β”‚ β”œβ”€β”€ cors@2.8.4
β”‚ β”œβ”€β”€ cron@1.3.0
β”‚ β”œβ”€β”€ express@4.16.3
β”‚ β”œβ”€β”€ express-session@1.15.6
β”‚ β”œβ”€β”€ follow-redirects@1.4.1
β”‚ β”œβ”€β”€ fs-extra@5.0.0
β”‚ β”œβ”€β”€ fs.notify@0.0.4
β”‚ β”œβ”€β”€ hash-sum@1.0.2
β”‚ β”œβ”€β”€ i18next@1.10.6
β”‚ β”œβ”€β”€ is-utf8@0.2.1
β”‚ β”œβ”€β”€ js-yaml@3.11.0
β”‚ β”œβ”€β”€ json-stringify-safe@5.0.1
β”‚ β”œβ”€β”€ jsonata@1.5.4
β”‚ β”œβ”€β”€ media-typer@0.3.0
β”‚ β”œβ”€β”€ memorystore@1.6.0
β”‚ β”œβ”€β”€ mqtt@2.18.0
β”‚ β”œβ”€β”€ multer@1.3.0
β”‚ β”œβ”€β”€ mustache@2.3.0
β”‚ β”œβ”€β”€ node-red-node-email@0.1.29
β”‚ β”œβ”€β”€ node-red-node-feedparser@0.1.12
β”‚ β”œβ”€β”€ node-red-node-rbe@0.2.3
β”‚ β”œβ”€β”€ node-red-node-twitter@1.0.1
β”‚ β”œβ”€β”€ nopt@4.0.1
β”‚ β”œβ”€β”€ oauth2orize@1.11.0
β”‚ β”œβ”€β”€ on-headers@1.0.1
β”‚ β”œβ”€β”€ passport@0.4.0
β”‚ β”œβ”€β”€ passport-http-bearer@1.0.1
β”‚ β”œβ”€β”€ passport-oauth2-client-password@0.1.2
β”‚ β”œβ”€β”€ raw-body@2.3.3
β”‚ β”œβ”€β”€ semver@5.5.0
β”‚ β”œβ”€β”€ sentiment@2.1.0
β”‚ β”œβ”€β”€ uglify-js@3.3.25
β”‚ β”œβ”€β”€ when@3.7.8
β”‚ β”œβ”€β”€ ws@1.1.5
β”‚ └── xml2js@0.4.19
β”œβ”€β”¬ node-red-contrib-ibm-watson-iot@0.2.8
β”‚ └── ibmiotf@0.2.41
β”œβ”€β”¬ node-red-contrib-mdashboard@0.1.5
β”‚ β”œβ”€β”€ serve-static@1.13.2
β”‚ └── socket.io@1.7.4
β”œβ”€β”€ node-red-contrib-play-audio@2.3.2
β”œβ”€β”€ node-red-node-ledborg@0.0.19
β”œβ”€β”€ node-red-node-pi-sense-hat@0.0.16
β”œβ”€β”€ node-red-node-ping@0.0.15
β”œβ”€β”€ node-red-node-random@0.1.0
β”œβ”€β”¬ node-red-node-serialport@0.6.7
β”‚ └── serialport@6.2.0
└── node-red-node-smooth@0.1.0

0 Likes

#15

You have installed mdashboard (node-red-contrib-mdashboard) which would stop the maintained node-red-dashboard from running.

But it looks as if you have not actually installed node-red-dashboard. Which is why you don’t see anything,
As you say you are a beginner, I would suggest you delete node-red-contrib-mdashboard and install the official node-red-dashboard which is the one your tutorial actually used.

0 Likes

#16

please guide me how to delete it can you list required commands ??

0 Likes

#17

Use the β€œManage palette” option under the node-red menu. You will need to delete any mdashboard nodes you have deployed re-deploy and then it should be self explanatory

0 Likes

#18

Hi
It works now , thank you and to all other for the support.
please i want to ask some questions
1- I couldn’t delete the contrib-mydashboard from manager palette since there was no option for removing but I was able to install the node red dashboard and now I can see two dashboards.
2- i was implementing a switch ON-OFF LED with raspberry pi3 so after finishing the project the led works fine but after switch the RPI off and switching it ON from main supply the and pressing the icon of starting up the node red the LED gose ON directly and this makes me worry about interfacing with RPI since it may damaging the process in case using many GPIOs , so is there any expalantion why the GPIO starting ON in starting the node red ??
3- is it possible to add some addons to the dashboard tools like some logic gates like OR,AND ,NAND …etc to be able to perform some controlling process?? and how
your reply will be highly appreciated
thank you a gain

0 Likes

#19

Answer to Q1:
To remove mdashboard go back to the command line and get into the .node-red folder and enter:
npm remove node-red-contrib-mdashboard
and that should get rid of it.

Answer to Q2:
You haven’t explained enough to get an answer. Are you using NR to turn the LED on/off? How? Maybe including your flow (place three backtick’s before and after the code) would allow others to see what you are doing.
Answer to Q3:
Why wouldn’t you do the logic in the back end flow? Then send the results to the dashboard?
A better explaination of what you want to accomplish would be helpful.

0 Likes

#20

In answer to #3, search on flows.nodered.org for β€œbool” or β€œgate” and you will see several nodes that others have written to implement boolean logic gates.

1 Like