Deploy button not working

Hello @knolleary , Thank you for the instruction.

When I remove the unnecessary flows and nodes, my deploy button is not working again when i include a new inject & debug node to check, kind of stuck. Always red. I can click it but no out put.No errors.

After following the above discussion I thought that it may work after deleting the log file. If it is not kindly correct me I want to start a fresh node red where my deploy button is working. I'm not sure how to do that.

Are there any errors in the browser's javascript console?

I just checked it aanndd yess.. there some errors as below :roll_eyes:

Your browser hasn't got the Node-RED editor loaded - so those errors are nothing to do with the deploy button.

I meant, once you are in the state where the deploy button is red and clicking it does nothing, then look at the browser console for an errors that happen when you click the deploy button.

I'm sorry now I got it. And it looks like below.

This is what I test >

Top flow - tested inject / debug node when they are with the other flow which loaded initially(flow1) and they worked. Out put in the debug panel is the top flows'.

Bottom Flow - I deleted the initially loaded working flow (flow1) and added a new inject/debug node. And then clicked the deploy button but it is not working. Then I obtained browser's javascript console.

Which of those errors in the browser log appeared when you clicked the deploy button?

I'm sorry now I think this is the correct one and in the same window I run the Ctrl+Shift+J. The bottom one is the error updating all the time when i click the Deploy button.
Here I have clicked the deploy button 17 times.

My log in the console looks like this

15 Feb 18:11:47 - [info] Starting flows
15 Feb 18:11:47 - [info] [worldmap:dabcad55.a2d0e] started at /worldmap
15 Feb 18:11:47 - [info] Started flows

Can you open the configuration nodes sidebar (selection the Configuration nodes option from the drop-down menu) and show us a screenshot that shows all of the nodes listed under there?

It looks like this. I obtained 2 screenshots until the scroll end.

So it looks like you have lots of unused ui_group nodes. I'm not sure why they would be causing the error, but I suggest you delete them if you aren't using them. Double click on each one and click the delete button in its edit dialog.

Actually I deleted all of them before as mentioned in the above discussion and again restarted the nodered. As I mentioned above the deploy button worked with flow 1 which loads initially and I think these nodes belong to that flow1.

Look, now I deleted them again and clicked the deploy button. But still the same :disappointed_relieved:

hmm.. well.. is there any way to start a fresh-node red ? I mean with working deploy button ? :roll_eyes:

... so why had they reappeared when you got those screenshots?

No matter - ideally we would debug this properly as clearly you have go into a state you should not have.

When node-red starts, it logs the name of the flows file it is using. If you want to fully reset things, delete that file and restart node-red.

In fact, please email me a copy of that file so I can have a look to see what state it is in - send to

not sure about where it is in the RPI i am runing widowns
maybe this whuld help

1 Like

Yeh ... it is confusing :disappointed_relieved: though i deleted them again they appear with the initial flow (flow1) where the deploy button is working. And when I delete that flow and started to test simple inject/debug > deploy button not working. Like a loop this situation happens to me :frowning:

Thank you very much for the support and spending time to help me. :relieved:

I'm sorry what do you mean by "delete that file" which file ? I mean I have tested by deleting he flow. But What is meant by "file" ? Is there any other place to delete ?

Again I'm sorry ,copy of that file means the flow (export of the flow) or what ? Kindly clarify it to me I will send the required files...

Thank you very much again for taking time to help me.

@emspe Node-RED stores your flow in a file on disk. As I said above, it logs the full name of that file when it starts. That is the file I would like you to send me and then delete (or move) so that when Node-RED restarts it does not load it.

Hello @aihysp , hmm yeh... im working with rasspberrypi. Thank you very much for sharing this. I will go through this.

well... i got it . Thank you for clarifying it. I think this is it :smiley:

15 Feb 19:38:20 - [info] Flows file     : /home/pi/.node-red/flows_raspberrypi.j 

I will send this.

Thank you very much again.

Hello @knolleary,

Ooops.. finally after moving that affected json file now... my node red is working... A huge relief after 5h + :sleepy:

Also I have sent you that affected file.

Thank you very much again for the support and taking your time to help me. :relieved: