Disable all - enable some - possible bug?

I installed node-red-contrib-chatbot
There are many nodes in this package.

No nodes were added to flows at this stage yet.
I disabled them all, they disappear from palette as expected.

Enabled a couple of them - they do not appear in the palette.
Closed the palette "manager" sidebar and reopened it
Enabled some more nodes, they started to show up.

Build some flows with these nodes, working nicely.
Restarted node-red (for other reasons).

The nodes were now "missing" in the flows (node-red started normally without error):

I cannot disable the nodes, nor enable others.
I cannot remove the complete package because it ends up with an error "node in use"
In the configuration tab there is nothing used/unused related to this package.

NR 3.0.2
Debian 11
node 16.18.1
npm 8.19.2

How are you trying to enable and disable the nodes?

Click the button, see the screenshot.

Has double clicking the actual node and trying the enable button (bottom left) been tried?

The nodes are "unknown". This is not relevant to the issue I am describing.

Have you tried group/drag selecting all the nodes (visible on edit screen) and deleting them (delete button) deploying then opening the config and looking for the config node assiciated with those nodes?
Delete it then remove it from the palette manager.

I know how to fix it. I want to focus on the issue described, which, to me, appears to be an internal node-red issue.

I think I can reproduce this issue.

Install node-red-contrib-chatbot, disable all nodes, enable some, they won't appear in the palette.
Close the "palette panel", reopen it, enable some more, they show up.

Add some nodes to a flow, deploy.
Restart nodered, nodes show up as unknown.

I hate to ask, but is this peculiar to node-red-contrib-chatbot, or does it happen with other packages containing multiple nodes?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.