Docker desktop ... node-red-contrib-alexa-remote2-applestrudel ... problems


I have NodeRED version 2 and I have had Alexa working until recently.

This is on my RPI with an IP of I did try and get it working on that one my updating "node": ">=16.0.0" But it crashed my RPI and it took many hours to get working, but it still has Node 12.

Another PC has NodeRED V3 and IP of In the future I wish to use Docker on a more powerful PC, so I have tried to get Alexa working using Docker on this PC.

I have got NodeRED working on it and installed node-red-contrib-alexa-remote2-applestrudel 5.0.48

I then get message open in your browser. I enter details and get ... Amazon Alexa Cookie successfully retrieved. You can close the browser.

Then I get in NodeRED "Unexpected end of JSON input".

In node-red-contrib-alexa-remote2-applestrudel 5.0.48 i have set the path to the same as above dummy text.
I look into the file where the Cookie should be and nothing is in there ?
I have tested that dummy text can be written to that file using NodeRED write file.
Somehow the browser isn't saving that data to that file ?

Any idea welcome as I am lost.

Thanks Gaz

I seem to have solved this part myself :grinning:
Instead of using the PC address which Docker desktop is running on ... I used
The cookie was then saved into my text file from the browser.

Now onto my next problem, Alexa isn't responding to commands, but I will start a new subject on here for that, as I think some others are having problems with Alexa responding :roll_eyes:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.