Enabling Projects feature - missing git

I am starting with node-red and notice a detail following a course.
In Settings, the option to connect to GitHub does not appear.
I did the installation complete, and I did not encounter installation errors.
Where is my fault?


Hi @enrique

The Projects feature is not enabled by default - you need to edit your settings file to enable it - https://nodered.org/docs/user-guide/projects/

1 Like

Thanks for the reply!

Yes, I modified the settings.js, in order to make the connection, but it does not show the Git Config label.
When lifting from the node, it displays the warning "Projects disabled: git command not found"

Just change the "false" to "true"

Did you stop/start NR after changing settings.js?
Also clear your browser cache and refresh the browser

1 Like

Hi! Yes, I made the changes with the NR stopped.
As a last step, I even reinstalled it, but the message still appears.

Did you install git?

1 Like

Yes - that is telling you the projects feature has been disabled because it cannot find the git command line tools.

From the docs I linked to:

The feature relies on having the git and ssh-keygen command line tools available. Node-RED will check for them on start-up and let you know if they are missing.

1 Like

Hi ghayne.

Yes, I have git installed.

I put it back to "false", and it correctly shows the notice that Projects is disabled for this reason. But changing it to "true" shows the warning that it can't find the command.

So if you type git in the same window you are trying to run Node-RED, does it find it?

1 Like

No, it did not appear.

I uninstalled everything and reinstalled it and Voila! now it's working.

I do not know what could be, I did not find anything strange in the log. But it is working, which is the important thing.

Thank you all for your patience!.

Did you try a reboot? It may be that the path in the terminal you were running in had not been updated to include the git path.


Hi Colin.

After a complete reinstallation it started working.

I've taken the liberty of changing the title of this topic to make it easier to find for others who may hit a similar issue


Yes, I know that, I was wondering whether you had tried a reboot first.

1 Like

Oh, yes, i reboot the services.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.