"Error connecting to PLC: [object Object]"

Hey Guys,

I am getting this error out of nowhere. "Error connecting to PLC: [object Object]". I am using a plc to send data forward through Http. Reading on previous topic didn't help me as no solution was posted there. I have only enabled the node in the exisiting flow.

What node is giving that error? Is it a contrib node?
Where is the error appearing?

I cant find any node which is giving this error. In the following screenshot, none of the node names match with the one giving an error. And even if I disable the entire flow, this error is being displayed.

If you use the search feature - ctrl/cmd F then look for the id of the node referenced - image
It should show which node it is.


This is what i got in response.

Have you tried a full deploy ? do you have some old hidden configuration nodes ?

When you deploy watch for the message in the deploy popup saying you have unused config nodes.

Yes i have. Same result. And i have some old nodes, but they are not related to PLC

If they are unused then delete them from the configuration nodes selection in the menu dropdown. Then uninstall any contrib nodes you have installed.

Thanks it got solved. Restarted flows after deleting unused S7 nodes.

1 Like