Filter errors in sidebar

Hi,
I'm using the node-red-contrib-s7 node to read from S7 PLC. Working fine.
But some PLCs are not in use 24/7. This produces the error: Error: connect EHOSTUNREACH
When working on a flow, often it overfills the debug sidebar with this errors. The errors are displaying also, if the filter is set to current flow, where no S7 node is present. How can I solve this?

Thanks for any hints,
Frank

Some thoughts:

  • Turn off the debug node.
  • Use a switch node to throw away payloads containing "EHOSTUNREACH".
  • Maintain an array of currently active devices and only show messages about these.
1 Like

There's no debug node active. As I have found out, the error is produced by node.js

In this flow I have selected a directly placed inject node, deployed it and select this node, then in the sidebar set the filter to "selected" node, no success, the EHOSTUNREACH error are still displaying.

Sorry, I assumed it was debug nodes.

Can you use a Catch node to handle the errors?

Actually I can't get "Filter this node" to do anything either, but I'm sure it works :wink:

Have selected the nodes which are producing the errors to a catch node with no debug output: no Chance, Errors still in debug sidebar present:

I assume that the error is coming directly from an S7 config node that you have configured to connect to a non-existent PLC. To stop those you will either have to remove that config node (which you probably don't want to do, if it is only a temporary shutdown) or contact the node author to get him/her to provide something like a checkbox in the node config to say whether you want the errors to be seen.

Thanks for helping. Have add a feature request: https://github.com/st-one-io/node-red-contrib-s7/issues/116

If outher users have this problem too, please leave a sign on Github to contribute this feature request.

Thanks, Frank