PLC connection dosen´t work

#1

Hey everyone,

i have got a Problem and Maybe you could help me with that. The Problem is that I started node-red and my Connection with the PLC does work. So it says it is online. But it always says too, that no Response from PLC, try connecting again. I tried this first with another SPS and there it went with the new SPS it does not go any more. The first PLC was a CPU 1516-3 PN/DP from Siemens and the second one is also a 1513-1 PN from Siemens. It´s the same Program.

I dont know what I should do. And I hope it is understandable.

Thank you in Advance for your answer.

Kind regards

MelSick

0 Likes

#2

Can you possibly share your flow, so it would be easier for us to help you?
For sharing flows please read before below post:

0 Likes

#3

It is not entirely clear from your post, was it previously working?
If so and you are absolutely confident that you have changed nothing in the software at either end then it must be a hardware problem. On the other hand the fact that it says it is connected but not receiving anything suggests it is more likely software.
What hardware is node-red running on and what is the communication method between the two systems? For example it might Modbus over ethernet.

0 Likes

#5

%C3%BCberblick

Variablen

Hello,
The communication runs over ethernet and in order to be able to connect everything with each other over ethernet, I have a router. Before I changed the PLC, the data transfer worked wonderfully. I inserted the nodes. I use the node S7 as input and a debug as output.

Kind regards
Melsick

0 Likes

#6

Hi @MelSick, developer of the node you're using here

It's not clear to me what your issue is, but since you're connecting to a S7-1500 PLC, I'd recomend you to check the notes regarding 1200/1500 series. Basically make sure to enable the bits on the PLC, so that Node-RED is able to access the memory areas you want. Also make sure you're getting the Rack and Slot parameters right, as it should be in your PLC project's configuration.

If you still can't make it work, please share with us the flow you have setup, and what kind of errors you're having and/or the Node-RED logs.

P.S.: Welcome to the Node-RED forum!

2 Likes