Error while installing Node-red same everytime i install

C:\Users\Acer>npm install -g --unsafe-perm node-red
npm WARN deprecated bcrypt@3.0.6: versions < v5.0.0 do not handle NUL in passwords properly
npm ERR! Unexpected end of JSON input while parsing near '...s":"~4.10.7","istanbu'

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\Acer\AppData\Roaming\npm-cache\_logs\2021-02-11T06_45_00_497Z-debug.log

this is the log

Welcome to the forum @punithreddy

You seem to have forgotten to include the log.