Error while setting the position property

I would like to set the curtain position by adjusting the 'position' attribute through Alexa. When I say 'Alexa, set the curtain to 50%', I'm receiving the expected 'msg.payload' from Alexa through Node-RED. However, upon sending the value '50' to the 'position' property, I receive a message in Zigbee2MQTT stating that 'position' is not a number. Any suggestions to resolve this issue?

10/01/2024, 07:33:57node: debug 1
msg.payload : number


I'm using a MOES MS-108ZR device - Zigbee + RF curtain switch module

    "calibration": "ON",
    "calibration_time": 10,
    "linkquality": 132,
    "motor_reversal": "OFF",
    "moving": "STOP",
    "position": 72,
    "state": "OPEN",
    "update": {
        "installed_version": 71,
        "latest_version": 71,
        "state": "idle"
    "update_available": null

Should you use the position property? msg.payload.position

I'm not sure where this can be done.


Oh i see, change the Payload option to msg then put payload

Perfect, it worked here. Thank you so much

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.