Failed Login when Trying to connect SQL and Node Red

So i tried to connect my node red and SQL. But it can't login with the current username and password. I checked and it is the correct username and password, i tried to make another username and it's still failed to login. Is there any step on settings to "enable" connect node red and sql? or I make some mistake when I created the username on SQL?

I am using node.js v20.9.0
node-red version 3.1.5
I used the node-red-contrib-mssql-plus node
Microsoft SQL SERVER 19


Did you try to use the ip address instead of the hostname ?

Is the SQL server a "SQL instance"?

How is node-red installed (in docker? Home assistant plugin?)

Is node-red on the same computer as SQL server?

yeah I tried, it doesnt work. but I think i put the wrong IP? is there any step to get SQL IP? or just using my network IP from CMD?

Sorry, I am new to this SQL things.

  1. SQL instance, based on what I read on Google, yeah it is SQL instance, I am using MS SQL Server Management. Am I right?

  2. Sorry again, I am not sure which one is it. But, I install it from CMD

  3. yes it is

Ok, so instances are typically not run on the default port number, you will need to find what was port number was dynamically assigned by SQL server to your instance and enter that port number on the sql config node.

You can look in the SQL log (using ms SQL server management studio) or you can browse the SQL log files in your file system). Some tips here: How to find SQL Server running port? - Stack Overflow

Also, try with and without the instance name from the host field.

More info here: Problem connecting to mssql express · Issue #63 · bestlong/node-red-contrib-mssql-plus · GitHub

thanks, I solve it. idk how, but I set some settings on that username and login the MS SQL with that username and password, and it works.