File path question (Linux vs Windows)

Hopefully an easy question about file paths for the bi-lingual Linux & Windows folks...

I have a flow that saves a file to a shared folder on a Synology NAS. I use the moment node (as instructed in this post) to create the file name. When running Node-RED on my Windows PC, I save to a specified Synology NAS location (which is, followed by the subfolders and other file naming stuff. And this flow works beautifully.

I then moved this same flow to a AWS-hosted Debian box on our network, and after going thru the NFS setup, I can see the drive when I use the df command:

But when I try to put various combinations of the file path into the Moment node (as I did on the Windows box), I cannot get it to work. Here is one combination and the error:


NFS permissions look fine on the Synology box (where the blacked out address is the Debian box)

I am almost certain I am missing a slash or a colon or some other small thing, but maybe more on the Debian box is required in order to map to this shared folder and use that path in Node-RED.

Try changing the :/at the end of the ip to just a /

Looking at the image, you have mounted the path to /mnt (which is odd but hey ho)

Try listing ls in /mnt - do you see your p-drive files?

If yes, then use /mnt/filename

Thank you both. Got it working now. Here's how (in case others in the future want to save files to a Synology NAS)...

These instructions (towards the very end of the page) that I originally followed show in their example to mount the Synology folders as follows:

sudo mount -t nfs 196.168.x.x:/volumeX/test /mnt

And I blindly followed the above, which mounted the path to /mnt (which in retrospect is odd, I guess). And when I later tried to do ls in /mnt, I was getting all sorts of permission denied messages. So I then undid (unmounted) the drive from the /mnt path and once back to square one, I followed these instructions instead and they correctly state to do the following:

Create a directory:

$ sudo mkdir -pv /synology-nas/Files

Mount the shared folder "Files" in the newly created directory:

$ sudo mount /synology-nas/Files

and from there, I just cleaned up some of the permissions on the Synology GUI and the final path that worked was:


1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.