Flow library stuck again?

I added and updated repos in the flow library 40 minutes ago and they still don't show up in the catalogue. Is the library updater stuck again?

Not to say I am smarter than you, but I have been caught on a similar problem myself.

How do you know they aren't updated?

Are you looking on the webpage/gui or from a CLI?

(Sorry. Not to seem like I am baiting you.)

Force a refresh on the browser if you are doing it that way.
That caught me big time a while ago.

1 Like

Now they finally updated...
The way I look:

curl 'https://catalogue.nodered.org/catalogue.json' | \
  sed 's/},{/},\\n{/g' | \
  egrep 'node-red-(fd|flexdash)'

(Using jq instead of sed would be more elegant but I always have to look up the manual...)

1 Like

Good to hear all worked out.

As i said: I wasn't wanting to show you up or anything.
I was just running in circles a while ago because I only refreshed the browser when should have force refreshed it.

1 Like

It wasn't a browser refresh issue or so, the catalogue wasn't being updated. Probably again only runs once an hour :cry:
Teaches me to try and push stuff to the flow library, best leave it out and be done with that...

Yeah, ironic that the faster computers seem to get the more patient you have to be with them.
I'm sure you remember computers in the 80's.
(Well, guessing.)

I'm not sure what you mean here. Why is leaving something out the best option?

The flow library catalog refreshes every 30 minutes. That's how it has pretty much always worked dating back to when it used to scan npm for updates automatically. Because the scan for updates was a very costly operation, we avoided running that too often.

Given how unreliable the npm API became for this, we scrapped the scanning and left it to users to manually add/update their nodes. However the task to regenerate the catalog has remained on that 30 min schedule.

It would be feasible to change it to refresh automatically when a nodes is added/updated. Just needs getting done.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.