Flows stopped due to missing node types. (mqttssl-broker)

Hi, can I know the steps in removing the unknown missing node in node-RED.

Flows stopped due to missing node types.

  • mqttssl-broker

I have tried removing this node from the 'manage palette' > 'node'
but the console window tells me it was an error.

Have you restarted node-red and refreshed the browser?

you mean stop the node-red in background and start it over again thru cmd right

This is what I found on the command window when removing the node in node-RED. It stops there. Can I know how to solve this problem. Thank you

Start node-red in safe mode. Once it is running, refresh the browser, use ctrl + f to search for mqttssl. Delete anything you find then deploy.

To start node-red in safe mode, enter node-red --safe

Yes, I have followed ur steps in removing it and restarting node-red in safe mode. However, the alert still popping up when I deploy my other nodes.
Is that I have to uninstall the whole node js and reinstalling.

If you have uninstalled the node module, you also need to remove the node from your flows.

That looks like a config node, so open up the Configuration nodes sidebar, look for any listed as Unknown, dbl click on it and click delete.

Thanks @knolleary @Steve-Mcl , I have solved the problem. Need to delete the node at the side bar of the configuration after removing all the unknown node in the 'manage palette'. Many thanks

Vincent, for future, as I mentioned, ctrl+f would have found it for you. Glad you're sorted.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.