Google assistant and node red setup

#1

Am a complete beginner in node-red and javascript stuff. Have been trying for the past few days to follow the guide in this page to get Google action to connect to node red so that I can use it to control my devices as part of a school project. am willing to learn. Link: node red Google action

I've tried alot over the past few days and learned the basics of express Web servers, ngrok, self encrypting node red and stuff but am still unable to establish the connection between node-red and Google action. Whenever I try to do so it just says that "test server is not responding, please try again later".

I've tried alot but I'm very sure I am still missing out some key things here. The first one is in the Google action input node, under port, url, ssl key and certificate I am unsure as to how I'm supposed to fill the values. (if possible i need a little spoon feeding here.)

2nd is I managed to have a Web server up and running through ngrok encrypted tunnel but I am not sure how I'm suppose to use it. (the Web server is just a blank https html page, or am I supposed to have something more?)

Sorry if the explanation was slightly confusing. Am abit lost on this topic. I'll be quick to reply so any help would be greatly appreciated :frowning: thanks!

Am going to try assigning a domain name from noip to my Web server, encrypting it and port forward to 443. Do u think that's necessary and better?

As detailed as possible would be great!!!

0 Likes

#2

A few weeks ago, @DeanC commented that he was working on a new version of node red Google action, I don't know when/if this will be released, but if imminent, it maybe worth waiting for it.

0 Likes

#3

Hi! Thanks for replying. Does this mean that the current Google action node has issues or sth? Else would be great if I could get this working

0 Likes

#4

My NR google action flow stopped working some months ago, which I suspect was due to some change by google. But in fairness, it was steep learning curve setting the flow up initially, and I lost the impetus to troubleshoot the issue when it stopped working...

I am hoping that Dean has somehow found a way to make this a lesser learning curve :thinking:

0 Likes