Google TTS node not working

I have had a flow where I use the node-red-contrib-google-tts node to convert a string into a url then the node-red-contrib-cast node to play the resulting audio on a Google Nest device for over a year. During the last week I haven't heard many announcements in the house so I ran some tests today and found it doesn't work anymore.

In the logs I am getting:

(node:537) UnhandledPromiseRejectionWarning: FetchError: request to https://translate.google.com failed, reason: connect ECONNREFUSED 0.0.0.0:443
at ClientRequest. (/config/node-red/node_modules/node-fetch/index.js:133:11)
at ClientRequest.emit (events.js:315:20)
at TLSSocket.socketErrorListener (_http_client.js:426:9)
at TLSSocket.emit (events.js:315:20)
at emitErrorNT (internal/streams/destroy.js:92:8)
at emitErrorAndCloseNT (internal/streams/destroy.js:60:3)
at processTicksAndRejections (internal/process/task_queues.js:84:21)
(node:537) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag --unhandled-rejections=strict (see https://nodejs.org/api/cli.html#cli_unhandled_rejections_mode). (rejection id: 6)

I have tried deactivating SSL for Node-RED but that didn't solve anything. The network hasn't changed.

Appreciate any help or insight offered.

Update:

I've put debug nodes on either side of the node-red-contrib-google-tts node and I can see messages going in but not coming out i.e. the flow halts.

Also, I have tried this on a fairly fresh install of Node-RED (on IOTstack docker) and get the same issue.

I suspect you may have to contact the author via the node's project page as it's not one I suspect many folk use regularly.

OK, it is fixed. Turns out it was my AdGuard DNS filtering. "translate.google.com" had been added to one of the blacklists it is subscribed to and that killed it. Hope this helps someone else in future.