Help: Cannot Delopy Node-Red to Cloud Foundry with Lite Account (worked before)

Hi!
I have created my IBM in March 2021 and have been using Node-RED with it since then. In August I was working on a project that needs to use MongoDB node. There were some incompatibilities with Node-Red version & MongoDB nodes back then, so I deleted and tried to reinstall the whole Node-Red service. However, when I reinstalled the service and tried to deploy it to Cloud Foundry as I did before, I got this notification that asked me to upgrade my account type. I am pretty much sure that I was having a lite account, but now I cannot deploy my Node-Red service. What is happening to my account? Can someone please give any solution to this?

(This is not the first time I tried to reinstall the Node-Red service, I did it once in August and it was fine. Because it still had an incompatibility issue, I figured I could try again but ran into this issue now. )

Thank you in advance!

You will now need to provide a Credit Card number to be able to deploy Cloud Foundry apps to IBM Cloud.

IBM Changed what you get on the free lite account towards the end of August, early September

See this SO question/answer for more details