Hidraw0 RPi3 vs RPi4

Hi there,

This is my first post. I am quite new on Node-Red, Linux & Raspberry Pi and I need your support.

I have an application running with a RPi3. I am building a new project with RPi4 and I want to reuse quite a few things and almost everyting is working just fine, except a device that I have it connected to one of the USB ports.

In the RPi3 I have an "Edit exec node" with:

sudo chmod 666 /dev/hidraw0

this is to stablish the initial connection. Then I also have several "Edit exec nodes" with the same command (just changing some sintax for different control messages) like:

sudo echo -e '\x00\x00\x00\x00\x00\x13\x00\x00\x00' > /dev/hidraw0

Like I said, the above works fine on the RPi3 but not on the RPi4.
I have tried similar approach with different values for hidraw* and dev/ttyUSB* after checking with lsusb that indeed the usb device is seen by the RPi4.

I hope some of you might have some suggestions that would help me to solve this issue.

THANKS in advance.

Look at udev rules to

  1. Identify the correct device
  2. Assign a fixed symbolic name to the now identified device

Search the site, there will be examples using serial ports you can use as a starting point

Thanks for your suggestions.
I will look into it next week again and I hope I will manage to get it working this time.

Thanks again.

You really pointed me in the right direction. I have now solved the issue. Big thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.