How to find a failing node

Every time I deploy, I get this error:

failed to load

When I click on the node number, my config tab opens. But which configuration is causing the error?

Try searching that id (ctrl+f)

Also you can click on the node id (where you have the arrow on your screenshot) and it should jump to the flow tab for that node and give you a flashing indication around it.

Normally, yes. But double-clicking only opens my 'config' tab, and it doesn't indicate which configuration is throwing the error.

This finds the node in 47 places, but only one configuration.
Since that configuration seems to be functioning OK, I can probably ignore the error.
But, I would really rather fix it.

so its a config node that causes the error .. i missed that part
what about disabling parts of your flow in order to pinpoint with the method of elimination where the issue is ?

What if you search no body - any hits for that?

Is this a help? I found it by googling for the error. "failed to load routines: "no body"" · Issue #191 · 586837r/node-red-contrib-alexa-remote2 · GitHub

Some. I tried most of the fixes in the thread and still have the error.
Everything seems to work regardless of the error, so I will ignore it for now.

Presumably that means that you are using that node.

In 47 places. I don't know if it's the configuration node or one of the 47 nodes that use it. I just don't like to see errors. Or warnings.

Seriously, I adopted the policy of fixing all warnings when I code on Arduino even if the program works. I think it makes me a better programmer because fixing warnings usually means learning something new.

You said earlier that clicking the node id took you to the config page, so it is the config node.

Definitely it is good to understand warnings and errors. I can only suggest asking on the node's github page.

What hode is it?

It's the node-red-contrib-alexa-remote2

have you tried using cakebake's version?

Instead of or in addition to node-red-contrib-alexa-remote2?

From what I read it is a replacement. Didn’t you read the link @Colin posted?