How to install the latest module version on Windows if plaette just shows the old one

Hi, there is a new version of a very powerful module, before installing it on RPi I want to test it on windows, but on the palette I can see only the previous version of 8 months ago. If I type the command npm install node-red-contrib-amazon-echo I have lot of errors that it can't create the folder system32/modules (or something similar). Where is the problem here? The palette belongs to Node red database and it takes some time to update the list? Or I need to force refresh my palette list? How?
Can I manually force the update? How? Thank you

I solved typing npm install -g node-red-contrib-amazon-echo but after I needed to install it on the palette too. Now in the palette I see the latest version 1.9
Somebody can explaing me what happened? Thanks

.... is the root of most evils.

Remove anything except node-red itself (and anything else that really belong in global - e.g. something that has a global command). Then install them from the palette. If something has the wrong version then, drop to the command line in your userDir and install the version you want manually.

1 Like

Hi, thanks for reply,
sotrry it's a bit difficult for me to understand, I just guess that "-g" is horrible parameter that should not be used, but honestly solved my problem.
So why now I?ve to reinstall anything? What went wrong? It seems all is working. By the way without this command I wasn't able to install the patest version, only after it I could see it on palette and install it.
May someone answer my questions to understand better?
what means -g?
why only after -g I was it in Palette?
If the Palette doensn't update with the latest version is a problem of my Node red or the central server of NR is not yet updated?
Thank you

I'll answer one of your questions:
the use of -g is not related at all to it appearing in the Palette. The palette shows nodes that are visible on, which is indexing all nodes on that have the keyword "node-red" set. Once they get updated on NPM, it will take several hours for the updated version to appear on the flows library, and thus to show up in the Palette. The several hours delay is normal. It appearing after you tried to install it using -g is purely a coincidence, nothing more, nothing less.

If you want the lowdown on why -g is such a problem, you will need to go back through this forum and do some reading. There are a lot of people who have invested a lot of personal time and effort trying to explain all of this repeatedly.

This is not to get at you at all, it just gets frustrating. The use of the global flag when installing modules is tied up with the use of npm and node.js. I would certainly encourage you to understand it but if you are just getting going, it is just a distraction. The instructions for installing Node-RED are very clear. Use -g to install Node-RED itself if you like which gives global command line access to it (there are in fact other ways that you can install it), but do not use -g to install nodes.

As soon as you start installing nodes with -g you almost inevitably end up with hard to analyse permissions issues that have all sorts of unintended consequences. Generally the easiest way out of that is to remove everything that you installed with -g and then reinstall it correctly.

If you are having problems with a Node when installed normally, there are a few problems that are most likely:

  • You installed 1 or more other nodes with -g and now are having permissions issues
  • The node requires special access to a resource that is not accessible to the user running Node-RED - in this case, the answer is to adjust the permissions, not to do a -g install
  • The author of the node made an invalid assumption about permissions or something else. In that case, you need to raise an issue against that Node on its GitHub repository.

Thank you a lot! I'll not use it more, it was just a suggestion of one site to install a module with -g and after that it was installing (before I got permission errors to write in system32). Unbelievable just few seconds after I checked palette and new version was there, ok that's a coincidence. I installed from palette, maybe the -g installation was not useful at all.
All is working, as I understand if I made troubles in NR installation I'll se on console or on debug that some errors may occour, by now no ones

1 Like