I don't arrive to send an email with node email

The email send failed. And I got this error message : "Error: Connect ECONNREFUSED ipaddres:465"

Someone have some suggestions ?

Are you trying to send via Gmail, smtp.gmail.com?

ECONNREFUSED means the mail server is not listening on either the port or host you have configured, you need to check that you have the correct details for the mail server

Yes I'm trying to send with gmail (smtp.gmail.com)

I think I have configured it well
For to : I have put the recipient of the email
For Userid : I have put the user and the email sender but the both doesn't works
and for password I have put the pwd of the sender.

Have you .....

GMail users

If you are accessing GMail you may need to either enable an application password, or enable less secure access via your Google account settings.

as found in the documentation on the node....node-red-node-email (node) - Node-RED

Yes I have already did it I have enable less secure access via my Google account settings

Well you may have to wait for a gmail user to help you on this one.
I run my own email server for my node-red stuff :frowning:

Ok no problem may be I will try with an other email than gmail.
Thanks you for your help !

I have several devices using gmail accounts to send emails but I always use the 'app password' generated by Google in the Security settings of your google.com account. I find the 'enable less secure device' does not always work.

1 Like

Ok thanks tou for your comment I will try this. After you get the app password you paste it in the password cell ?

Yes, follow further down the security settings page and create an app password.
Keep a copy of the password for your records.


1 Like

Thanks for your message but I have always the same error.

And after some manipulations I don't have anymore the palette menu in Node-RED and have this message when I write this : "node-red" in the command prompt :

Hi nke9, the current version of Node-Red is v1.3.5 and current node.js is v12.22.2 or more so you should consider upgrading. Also my version of linux is 5.10.17-v7+.
That might help.

1 Like

Tanks you for your help nyghtrider, I can't update the version of my linux but I can try to update node.js and Node-RED.

OMG .... upgrade @nke9

This reminds me of my Dad in year 2003 running a 233mhz from mid 90's trying to be online....
ME: "Dad you need a new computer"
DAD: "....but its a Pentium"

But I do have some old node-red pi's out there in the network that never give me trouble
Screenshot from 2021-08-24 05-15-34

oh god ... I've become my old man


I can't upgrade because it's on an embeded system.
So it's possible that my error doesn't come from the version of Node-RED.

What version of the email do you have installed?
You can find out by going to the palette managed.

The problem is that I can't acces anymore to the palette managed.

You probably need to update npm too.

Make sure you have a full backup then run the install script.

bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered)