I have an error but can't figure out which node

#1

Hi! I have the following error:
4/2/2019, 13:49:24node: a0019baf.2b4678

msg : error

"Error: EBADF, Bad file descriptor"

I can click on node: a0019baf.2b4678 but it doesn't select any node in the flow, so how can I guess which node is it? Thank you

0 Likes

#2

Try using the Search feature to search for the node number. If that doesn't work then I think that means that it is in a subflow.
However that error suggests that it may be something reading or writing a file. If you have any such nodes then give them names and then the name should appear in the error.
Also check that you have a recent version of node.js, you can see that using
node -v
if should preferably be 8.x.x or 10.x.x. though I think 4.x.x is still ok.
If still no joy then post the complete startup log from node-red and that may give us a clue.

0 Likes

#3

thank you for reply, I have v10.15.0
If I search a0019baf.2b4678 I have some results but if I click on all arrows no results after.. even if I search only part of those nubers.
So how I can figure out which node is it? Maybe is out of my flow? Maybe a program lounched by a module?
Thank you

0 Likes

#4

What sort of result do you get? Does it not give you at least a basic hint as to which of your nodes it is? The search result will include the icon for the node - that should help narrow down the type.

The other possibility is whether you have any subflows? It could be a generated id of a node inside a subflow instance - which can be hard to track down unless you set the name field on the nodes as Colin has suggested.

0 Likes

#5

Also please post the node-red startup log.

0 Likes

#6

Here it is the log: (i tried to remove // from links), sorry for delay on answer. As suggested in other thread I've already wrote in github about node-red-contrib-lcd20x4-i2c. Could the problems be connected? Is the log at startup and error?

pi@raspberrypi:~ $ node-red-stop

Stop Node-RED

Use node-red-start to start Node-RED again

pi@raspberrypi:~ $ node-red-start

Start Node-RED

Once Node-RED has started, point a browser at http: 192.168.1.251:1880
On Pi Node-RED works better with the Firefox or Chrome browser

Use node-red-stop to stop Node-RED
Use node-red-start to start Node-RED again
Use node-red-log to view the recent log output
Use sudo systemctl enable nodered.service to autostart Node-RED at every boot
Use sudo systemctl disable nodered.service to disable autostart on boot

To find more nodes and example flows - go to http://flows.nodered.org

Starting as a systemd service.

Started Node-RED graphical event wiring tool.
6 Feb 19:54:29 - [info]
Welcome to Node-RED

6 Feb 19:54:29 - [info] Node-RED version: v0.19.5

6 Feb 19:54:29 - [info] Node.js version: v10.15.0
6 Feb 19:54:29 - [info] Linux 4.14.79-v7+ arm LE
6 Feb 19:54:30 - [info] Loading palette nodes
6 Feb 19:54:40 - [info] Dashboard version 2.13.0 started at /ui
6 Feb 19:54:40 - [info] Settings file : /home/pi/.node-red/settings.js
6 Feb 19:54:40 - [info] Context store : 'default' [module=memory]
6 Feb 19:54:40 - [info] User directory : /home/pi/.node-red
6 Feb 19:54:40 - [warn] Projects disabled : editorTheme.projects.enabled=false
6 Feb 19:54:40 - [info] Flows file : /home/pi/.node-red/flows_raspberrypi.json
6 Feb 19:54:40 - [info] Server now running at http: 127.0.0.1:1880/
6 Feb 19:54:40 - [warn]

Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.
You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

6 Feb 19:54:41 - [info] Starting flows
pi : TTY=unknown ; PWD=/home/pi ; USER=root ; COMMAND=/usr/bin/python -u /home/pi/.node-red/node_modules/node-red-contrib-lcd20x4-i2c/LCD20x4-I2C/lcd20x4_i2c.py writelcd 20x4 2
pam_unix(sudo:session): session opened for user root by (uid=0)
6 Feb 19:54:42 - [info] [mosca in:50deaca8.77738c] Binding mosca mqtt server on port: 1883
6 Feb 19:54:42 - [info] [tcp out:Dimmer WiFi Bridge] connecting to 192.168.1.254:8899
6 Feb 19:54:42 - [info] [tcp out:Denon Amplificatore] connecting to 192.168.1.252:23
6 Feb 19:54:43 - [info] Started flows
6 Feb 19:54:43 - [info] [mqtt-broker:mqtt] Connection failed to broker: mqtt://192.168.1.251:1883
6 Feb 19:54:43 - [info] [tcp out:Dimmer WiFi Bridge] connected to 192.168.1.254:8899
6 Feb 19:54:43 - [info] [tcp out:Denon Amplificatore] connected to 192.168.1.252:23
6 Feb 19:54:58 - [info] [mqtt-broker:mqtt] Connected to broker: mqtt: 192.168.1.251:1883

0 Likes

#7

I don't see the error there. I would have expected to see it in the log. Where exactly are you seeing it?

0 Likes

#8

Sorry, I have just realised where you are seeing the error message, it is in the debug side bar. I don't understand what you mean by "I have some results but if I click on all arrows no results after". Perhaps a screenshot would be helpful. I would only expect one result if you put the full id in.
When you click does it change tabs in the editor (try switching to a different one then clicking again to check). If so then probably the node is on that tab but maybe off the screen, it doesn't always pull the node into the visible area.
Looking again at the error I think it may be from a debug node set to show the complete message. Probably you haven't got too many of those.

0 Likes