IBM Bluemix node red HTTP security issues

Hi.

We are running Node-red on a local machine "ComputerA" with port forwarding enabled. make changes in the settings.js file to add the HTTP node security. as per the Node-red docs

httpNodeAuth: {user:"user",pass:"$2a$08$zZWtXTja0fB1pzD4sHCMyOCMYz2Z6dNbM6tl8sJogENOMcxWV9DN."},

We have generated credentials using bycrpt generator. make a simple HTTP in flow with response node.

On another computer "Computer B" on a different network, i can send a post request to computer A with the basic authentication and it works OK.

OK.
I try the same thing with IBM bluemix. Altering the bluemix-settings.js. push the changes, the delivery pipeline completes.
I then send the request to the bluemix node-red version. doesn't matter if I have the basic auth enabled or not the message gets through. Its like it doesn't pick up the settings.js.
I restarted the app as some other people have done according to this forum, still no change.

Any ideas?

Thanks

Issue was solved.
I had deleted the deploy stage in the delivery pipeline as it was failing.
After some researching i found that you have to stop node red to free up resources so the delivery stage can complete.

  • I added the deploy sage back to the tool chain

  • Stopped NodeRED

  • Run the deploy stage, it passed, finally!

  • Restarted node red, and bingo the HTTP Auth worked.