Ical config impossible to remove


I try to work with node-red-contrib-ical-events to get information from a schedule but for the time being it does not work on my side.

I would like to remove the palette from node red but i've got the informations

On the left hand side i've got only 3 nodes instead of 4 ?

bug ical
information from palette

Does anyone got solution for this kind of issue ?

hello @JFLOG, welcome to the forum.

Go to "Configuration nodes" on the right

Click "Unused" and you should see the ical-config node below "On all flows".

Double click on it and in the popup click delete.
Deploy and you should be able to uninstall the ical nodes.

The already registered error means that the node conflicts with another node you have installed. You can find which by stopping node red and restarting in a command window and inspecting the startup log there.
If you want to remove it and @jbudd's suggestion does not help then you need to remove it manually. If you have a normal node red install then, in a command window, cd into your .node-red folder and run
npm remove node-red-contrib-ical-events
It should say that it has removed nodes.
Then restart node red and refresh the browser page.

Do you have more than one ical node installed? The reason I ask is that node-red-contrib-ical-events nodes show a brownish yellow while node-red-contrib-ical-schedule nodes show as a light blue.

Do you have both installed? The easy to determine is to go to the hamburger menu (top right in editor) and select Manage palette then search for -ical- and see what you get back.

Tanks for each answer i've tried but i'm still stuck

from jbudd i can remove but from unsued area bur i cant remove from manage palette

From Colin
I went into the node-red folder but i cannot remove contrib-ical here is what i've got on my screen

Check in Manage Palette for any nodes that can be updated, and update them. Then try the remove again.

Hello Colin

I've tried to update but i had the following information

I've decided to save nodes ans i've deleted node-red from my labtop.and in order to load the last version.

I've leaved only one flow and i've reload ical from palette management to get the last version.

Now i'm testing and it seems to work

Tanks for your help

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.