Industrialcomm (S7comm) Error/Info

Hi, there,

I am new to this, so please don't mind my ignorance.

I am running industrialcoom/S7comm with PLC S7-200. Everything seems to work well. Sometimes I get comm.error but that's very rare, When I start RPI I get following S7 error messages in my log, I don't understand why, can anybody tell me?

Welcome to Node-RED

25 Oct 13:36:30 - [info] Node-RED version: v2.1.1
25 Oct 13:36:30 - [info] Node.js version: v15.12.0
25 Oct 13:36:30 - [info] Linux 5.10.17-v7+ arm LE
25 Oct 13:36:32 - [info] Loading palette nodes
25 Oct 13:36:34 - [s7comm-Error] - Installation of Module net-keepalive failed because we might be on the wrong OS. OS=linux
25 Oct 13:36:34 - [s7comm-Info] - Debug configuration for logLevelNodeS7:{"debug":0,"silent":true}
25 Oct 13:36:34 - [s7comm-Info] - Debug configuration for logLevelNodeRED:{"debug":2,"silent":true}
25 Oct 13:36:36 - [info] Dashboard up and running
25 Oct 13:36:37 - [info] Dashboard version 3.0.4 started at /ui
25 Oct 13:36:37 - [info] Settings file : /home/pi/.node-red/settings.js
25 Oct 13:36:37 - [info] Context store : 'default' [module=localfilesystem]
25 Oct 13:36:37 - [info] User directory : /home/pi/.node-red
25 Oct 13:36:37 - [warn] Projects disabled : editorTheme.projects.enabled=false
25 Oct 13:36:37 - [warn] Flows file name not set. Generating name using hostname.
25 Oct 13:36:37 - [info] Flows file : /home/pi/.node-red/flows_pipi.json
25 Oct 13:36:37 - [info] Server now running at http://127.0.0.1:1880/
25 Oct 13:36:38 - [info] Starting flows
25 Oct 13:36:38 - [info] Started flows
25 Oct 13:36:39 - [info] [tcp in:P1 digitale meter] listening on port 8432

I recently noticed I have the same problem. I migrated the node-red server from Windows to Linux and now I get this same error.

I'm using it with S7-1200 and S7-300 PLCs.

2 Nov 14:50:10 - [s7comm-Error] - Installation of Module net-keepalive failed because we might be on the wrong OS. OS=linux
2 Nov 14:50:10 - [s7comm-Info] - Debug configuration for logLevelNodeS7:{"debug":0,"silent":true}
2 Nov 14:50:10 - [s7comm-Info] - Debug configuration for logLevelNodeRED:{"debug":2,"silent":true}

1 Like