ISSUE: v2.1.4 HA connection

It seems I can't connect to a Home Assistant server in 2.1.4.
It's not possible to "add a new server"

  • Using Node Red in Docker.

Hi.

  • What node is this (Node-red-contrib-????)

  • What browser are you using?

  • Can you check your browsers console for errors (press F10 to access browser console)

It's any note - the screenshot is from this one

image

I am using Chrome.

"breeders console" ? - do you meen if there are any javascript errors reported in the browser?

When I open the note there is an error in the browser console.

I did indeed (stoopid autocorrect) :smiley:

What happens if you use the IP of the device rather than host name?

PS: there are not a great deal of HA users on this forum - it is possible this is a well known issue on the HA forum

I am missing the "Server Edit" button from the field. Orelse I have no where to input in the HA credentials.

It used to look like this:

image

I looked at the file node-red-contrib-home-assistant-websocket.json in the NodeRed folder and if I delete and restart NodeRed it is recreated. But it is empty:
{}

Maybe the error is that this file should be filled properly. Anyone can check a working instance and see what your file says.

Also this was in the log:
[node-red-contrib-home-assistant-websocket/server] Error: Cannot find module '/data/node_modules/has/src'. Please verify that the package.json has a valid "main" entry

Trying reinstalling the HA Websocket integration package as it appears you may have a corrupted install

Craig

Since it's run in Docker I just tried recreating it. Both with latest version and version 1.3.5.
Same issue - So the data must be bad somehow.

I gotta do some more testing.

I think I found the issue

Burger Menu > Manage Palette:

I am guess that the error "[object Object]" is the reason it's not working.
Clicking update to 0.41.3 generates and error in the log.

2022-01-11T07:05:47.762Z Install : node-red-contrib-home-assistant-websocket 0.41.3
2022-01-11T07:05:47.759Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict node-red-contrib-home-assistant-websocket@0.41.3
2022-01-11T07:05:52.983Z [err] npm ERR! code Unknown system error -74
2022-01-11T07:05:52.983Z [err] npm ERR! syscall unlink
2022-01-11T07:05:52.983Z [err] npm ERR! path /data/node_modules/.has-symbols.DELETE/test/shams
2022-01-11T07:05:52.983Z [err] npm ERR! errno -74
2022-01-11T07:05:52.988Z [err] npm ERR! Unknown system error -74: Unknown system error -74, unlink '/data/node_modules/.has-symbols.DELETE/test/shams'
2022-01-11T07:05:53.003Z [err] 
2022-01-11T07:05:53.003Z [err] npm ERR! A complete log of this run can be found in:
2022-01-11T07:05:53.004Z [err] npm ERR!     /data/.npm/_logs/2022-01-11T07_05_52_993Z-debug.log
2022-01-11T07:05:53.011Z rc=182

I tried creating a completly new docker instance and importing my flows there. That seems to work much better and I must therefore conclude that the my original instance has gone bad.