Issues with Blockly 2.4.0

Hi ,
I have just installed Blockly 2.4.0 into my Node red and are have mouse issues with the node.
If i click on any blockly item it moves into the workspace but then the block moves everywhere the mouse moves to , I cannot drop the block whatever button I click or key I press the block still moves.
I cannot see what I am doing wrong ?

I have tried it on a Linux system and a windows system same problem
i have also tried using Edge and Firefox browsers still the same problem

any help would be appreciated.

Are you using NR within Docker because there is an unresolved issue with it

Otherwise, I'm stumped as its all working fine of my Windows/Pi machines

But if not on Docker - what version of NR are you using - what version of node.js?

hi thanks for replying,
No not in docker

I am using NR V3.1.3
Node.js V18.19.0

Is it the same effect as the Docker issue or can you not drop any block no matter where you grab it?

FYI I'm either on 18 or 20 on my machines - running node 19 is probably not the issue but maybe worth updating to v20 just to make sure

yes it is the same effect just viewed that now

Lets see if moving to node v20 makes any diff then

sorry i am on node 18 shall i still try 20?

I just checked my Pi and it was on 20 and well as my windows machine

I don't think it'll be the cure but always nice to be on the same page :slight_smile:

ok thanks not sure how to do that but will look it up ;~)

On a debian linux machine- just run the installer script again with ---node20 on the end of it

On windows - go to node.js website and run the node20 installer

thanks again! i will do it now

Just to check, I ran my Docker instance and got a bash shell inside it and it is using node.js v18 so it could just be the reason

Hi me again :wink:
My linux machine fails on an install to node.js 20 so had to revert back to 18
Need to get some work done now so will look into it again later.

Thank you so much for your time today

1 Like

Well - I tried downgrading a Pi5 running bookworm to v18 - and I then I got the issue

Unfortunately - upgrading it back to v20 did not get rid of it!

So I'm a bit stumped now :frowning:

opppsss sorry me bad!
hope you get it working

For @BartButenaers when he pops in here
On the non-working Pi5 instance I'm seeing this in the console if I'm just dragging a block around

(I don't get this in a working instance)

And then I get his error when I click in the text box (and unable to drop the block as per the Docker issue vid)

Well - I just installed NR in a brand new Linux Mint VM and I get the issue :frowning:

So, The question is how come it is working fine on both an existing Pi and Windows that are running NR3.1.0/3.1.3 node V20 and Blockly node 2.4.0

1 Like

yes strange ? sorry i put you to all this trouble. Just glad it was not something silly i was doing.

1 Like

Could it be that - by installing our node - you got a more recent (minor) version from the blockly package, which contains a bug?

I'll have check on my Blockly versions