Issues with homekit module after node-red update

Hi Everybody,

I have a problem with homekit module - accessories are "not responding" after a random time. The same happens after each restart of node-red.
The reason I am writing this here is that my problems started after updating everything: node.js, node-red and the appropriate homekit module. Before everything worked for months without issues.
The problem is I don't know which versions I was using prior to the update. Since then I deleted everything couple of times and tried different combinations of versions. (certainly I have tried node.js v8.9 since I think it was the old one but then I can not switch to older node-red or the older version of the homekit-bridged module)
The same problem occurs with every of the available homekit (bridged or not bridged) module.

The machine hosting node-red is running under windows server 2012 r2. Initially I thought this is due to bonjour problems on windows but I can see the created homekit bridge or single accessories (depending on the installed module) in the bonjour browser.

On the client side there where no iOS updates in the meantime (and the IKEA Tradfri lamp is still working just fine).

Therefore I am sure the problem sits in the node.js or node-red.
Right now I have node v10.16.0 with npm v6.9.0, node-red v0.20.6 and node-red-contrib-homekit-bridged v 0.6.2 running. Windows firewall is completely turned off for test purposes.
I am communicating with a bunch of sonoffs and esp8266's dev boards running micropython via mqtt and everything works perfectly from dashboard. Homekit and dashboard are the only extras added to node-red.

If anybody knows how to configure the setup correctly to solve this problem please feel free to help me out :slight_smile:
I will be also happy if you could just point into the right direction. I am not sure how to even diagnose the issue, since no errors appear on the console.

PS. Sometimes randomly after a day or a rather long time homekit responds by itself but after switching devices couple times it losses connection again with a "not responding" message.

Thank you

If you have the same issue with several nodes the chances are there's an issue with the underlying library.

But one thing to check...
Have you re-installed the library following the instructions node-red-contrib-homekit-bridged?
Have you rebooted your device? There was an issue with the avahi module not resetting properly a while ago, which a reboot would clear.

If you have done the above I'd suggest opening an issue against the node-red-contrib-homekit-bridged node as it is still appears to be being actively developed.

This issue occurred so often in my setup that I got rid of homekit in node-red and moved over to homebridge-mqtt and never looked back (it requires homebridge and a different mindset), extremely fast to add/remove/update devices with custom "services" and all done using MQTT and the "not responding" always disappears quickly.

Hi ukmoose
I did re-install from within palette-manager, manually from the command line and even did erase what was left behind in .node-red folder etc.

As far as I understand, under windows bonjour does what avahi under linux. That was my first suspect therefore I rebooted the machine but also restarted bonjour service/deamon on other occasions.

If nothing helps I will try my luck there. Thx

Hi bakman2
I was using homebridge prior to switching to node-red. I wanted some more control over the behavior of my devices and hard code some automations. Since then I became a fanboy :slight_smile:
I will look into packages roaming on my network perhaps there are some issues similar to what I found here ( - but on the other hand I switched off the firewall to make sure everything is visible and can talk to each other.
I might also check if a docker container provided by a homekit node contributor will work for me.


I know, I am the same way, I only use homebridge for homebridge-mqtt, which is fully controlled via node-red. tbh I cannot recommend this enough for homekit as the homekit nodes simply don't work as smooth and stable as this.