Keine Verbindung zum SQL Server 2019

Deutsch:
Ich bekomme keine Verbindung mit dem SQL-Server 2019 EXPRESS. Habe einen simplen Flow erstellt, der auf einen Tastendruck eine Anfrage einer Funktion in die MSSQL Funktion übergibt. Ich erhalte immer den Fehler:
"ConnectionError: Failed to lookup instance on DESKTOP-7R5OQBV:1433 - getaddrinfo ENOTFOUND DESKTOP-7R5OQBV:1433"

Die Serveradresse habe ich aus dem SQL-Server herauskopiert.
DESKTOP-7R5OQBV:1433\SQLEXPRESS01

Habe es schon mit 127.0.0.1, localhost, mit und ohne Port (ohne gibt es einen undefined Port Fehler), mit Encryption und ohne ...

Ich lasse den SQL-Server auf dem gleichen Rechner laufen, wie Node-RED.
Den Server-Browser habe ich gestartet, die Sicherheit auf Server+Windows-Authorisierung gestellt, den Server mehrfach neu gestartet ...


Danke für Eure Hilfe!

English:
I can't get a connection to the SQL Server 2019 EXPRESS. Have created a simple flow that passes a request from a function into the MSSQL function on a keystroke. I always get the error:
"ConnectionError: Failed to lookup instance on DESKTOP-7R5OQBV:1433 - getaddrinfo ENOTFOUND DESKTOP-7R5OQBV:1433"

I copied the server address from the SQL server.
DESKTOP-7R5OQBV:1433\SQLEXPRESS01

Have already tried it with 127.0.0.1, localhost, with and without port (without it gives an undefined port error), with Encryption and without ...

I run the SQL server on the same machine as Node-RED.
I started the server browser, set the security to Server+Windows Authorization, restarted the server several times ...

Thanks for your help!
Steffen

Welche Einstellungen hast du auf der SQL Node getätigt?

You might have to enable sql server authentication on SQL server & add an account.

then try this...


PS: This uses the newer & supported node-red-contrib-mssql-plus

Hello,
first of all, thank you very much for the feedback.
Unfortunately it still does not work.
I have now uninstalled mssql and then installed mssql-plus.
Here are my settings and the current error:


I can't find an approach (I guess I lack the expertise here) on how to find the error. Is it possible that it is the wrong port? I have found it on the Internet. Is it possible to read it in the SQL server? I also tried 127.0.0.1 - without success => same message.

Thank you very much!

Yes. This is often the case with named instances. You need to look in the SQL log.

Loads of information on the net regarding this. E.g....

"How to find the TCP Port number your SQL Instance is listening on | Popdock" How to find the TCP Port number your SQL Instance is listening on | Popdock

Hello,

thank you very much, this has given some push towards success.
a) I have noticed that in the Config Manager, TCP was on inactive, I have now changed to active.
b) Under all IPs, no port was entered - I have now entered the 1433 at IP8: 127.0.0.1.

Then I restarted the server and retriggered my command. Now I get stuck at the next point. I have tried there now 2 hours around. Now the error comes:

I created the user NODERED in the security of the SQL server:

Can it be that some other basic settings or basic parameters are missing?

BR

Perhaps this ist helpfull?


What does it mean?

I just can't get on, I have searched the internet and find many hits, but can't do anything with the topics discussed.
If no one can help me here, then I try to find a SQL forum.
Thanks a lot for the help so far. If someone still has an idea or I should show anything, then please feel free to write.
THANKS!

I did it, the error is gone. I deleted the user and then created a new one.

Now the error comes:
image

Seems to be related to the STRING content, now I have to see how to make a STRING - more STRING. If anyone knows the solution - am grateful for any help that shortens my search.

Hello,

Problem solved.
Thanks to all who helped me.
Result: lack of basic knowledge.
I have still manually adjusted the user rights in the server. Here the access permission to the table was missing. Also a ' at the beginning and end of the string was missing.

Greetings