Layout Editor - Drag and move feature problem


When I installed node-red ,Dashboard layout editor was working fine.As I am still in learning phase, I had installed and disabled multiple templates.

Some how now,the Drag and move feature in layout editor,is not working.
I am unable to drag icons, is there any setting which I can reconfigure ?

@dceejay - Hi, I just read your last post , in sep 19.I am editing the original message.
Not sure if its right to tag somebody, I just want to find quick solution because, I have made huge flow and now suddenly the Layout editor is behaving unusually.
Please help if you know how to solve it.

Thanks and Regards,

Click on the little lock for enabling resizing.

Hi @bakman2,

I tried that in the first place.Earlier there was a small re-size link coming at bottom right corner.
Now when I click on lock ( to unlock) - the module just gets resized to complete tab size.

Yeah sorry it's early here, always confused by the lock :wink:

If the lock is "locked" you can resize the elements.

I am unable to resize, the resize link is not appearing.
Earlier it used to come automatically, but now its not showing.

I am also unable to drag and move the modules, earlier i was able to do it.
I am sure there is some configuration issue.

Did you set your gauge size to auto ?

Yes , they are in auto, still the icon is not showing.
Earlier even if the auto is not set, I was able to move the icons.

When I moved to align earlier , the layout editor was automatically adding spaces, but now all those things are not happening.

I think there was some issue with browser cookies , all works fine after clearing the cookies.
But restarting the browser after clearing the cookies did the trick.

Actually I don't know how it worked again,I also did a system restart. :confused:

1 Like

If you upgrade the dashboard version you need to flush the cache to ensure there is not "old" code left on the browser side that may not "line up" with the version on the server side.

1 Like

The problem happened again.
It happens specifically when working with gauges.
For Eg:
If I drag and move modules in layout editor, it adds spaces to the ui automatically.
Now if I re-align ,multiple spaces are added (depending on layout ).With this there are multiple space objects being created( I checked in configure nodes).

If I am not adding mode ui nodes, it works fine.
But if I add ui gauge or ui linear gauge, the layout editor stops working and the whole theme I created seems disturbed.

So the solution to this which works 100% without deleting any nodes is , deleting the space objects from node configuration and also deleting all unused groups and then restarting the browser after clearing the cookies.

Such a simple problem , but If somebody gets stuck ( at beginner level like me) he might not know.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.