Losing connection with the server

Hi! English is not my native language so forgive any mispelling.

  1. My very first time with Node Red;
  2. I did a fresh install in my Raspberry Pi 3B+ running the script that I found on nodered.org;
  3. I just installed "node-red-contrib-lgtv" so I can do some automation with my LG TV;
  4. The error on the title always occurs when I add my TV's IP in any of the nodes. I just click "connect" after typing my IP and when I deploy I lose connection with the server.
  5. My TV is wired. I tried changing to WiFi, tried changing VLAN and also connecting the TV in the same network as Raspberry Pi but no success.
  6. In order to get things working again I need to enter in safe mode and delete the node;
  7. I'm using Edge on Windows 10 to access the dashboard.

Am I doing something wrong? :frowning:

There is an issue on github about this node crashing Node-Red v2

It has not been updated for more than 2 years so there may be nobody to fix the issue.

1 Like

Thank you very much! At least I know now that It may be not my fault. Unfortunately I was trying Node Red specifically because of this node once I'm a SmartThings user and needed to integrated both. :frowning: :pensive:

There may be other ways to access it. Perhaps some internet searching would turn up ways of interacting using HTTP(S) requests? (AKA a REST API).

1 Like

You could always run the script again and specify an older node-red version known to work with the lgtv node. Although I don't know what that version would be.

1 Like