MAX31856 thermocouple amplifier

#1

Has anyone been able to get the MAX31856 to work in node-red? There is a node for it bute when trying to install, I can never get it to show on the UI.

0 Likes

#2

Really ? Which node is it ? Did you check it’s readme on npm or GitHub for any pre-reqs or other info.

1 Like

#3


This is the one I was trying to use.

0 Likes

#4

So what command are you using to install it?
What directory are you running the command?
What OS are you running Node-RED on?
What version of Node-RED?
What version of Nodejs?

(the last 2 are found in the startup messages of Node-RED)

0 Likes

#5

Raspbian Stretch
Node-Red 0.18.7
Node.js 8.11.3
NPM 5.6

/.node-red dir

npm install (downloaded and uncompressed file name)

0 Likes

#6

Have you tried installing direct from git?

cd ~/.node-red
npm install git+https://github.com/kaelfischer/max31856-nodered.git

0 Likes

#7

I have tried that way.

0 Likes

#8

SOLVED!- I figured out the issue with installing the node, I needed to update NodeRED. Thats done and now the node is installed I don't know if it works yet, I'm waiting on a part. I'll update later on

I have downloaded and installed the above node but its not showing up in the node list. Was that the same problem you were having? I'd really like to get his thing to work. I have some time off at the end of the month and was planning on fixing my oven and BBQ. any help you might have on fixing this node would be great.

Thank You very much

A bit more info... it is showing up in the pallet manager with an error that says
"SyntaxError: Unexpected token * (line:3)" quotes are mine

0 Likes