MH-Z19C Timeout?

Hello !
I have a small problem with my co2 sensor, the mh-z19c.
When I first connected it, it worked just fine.
But now i have the problem, that below the mh-z19 node the report "timeout" shows, with small red dot infront of it.

Has someone the same problem and could help? I don't know what to do.

Thanks and best regards.

You have to supply us some more info.
Post the relevant part of your flow here.

Thanks for your answer.
Like I said, at first everything worked fine, but suddenly, without any changes, this "timeout" report appeared. I researched it but couldn't find anything. I hope to find help here.
Screenshot 2021-05-09 142618

What is the full name (nodered-contrib-????) of the node you are using?

add a catch node connected to a debug node (set to show the complete msg object) to the tab you flow is on.

Also check the node-red log to see if there is anymore information.

The full name is : node-red-contrib-easybotics-air-quality.

I did connect a catch node like so :
Screenshot 2021-05-10 114841

But nothing happened, i got no reports at all and the debug tab on the right side remains empty.

I set the catch node to "all nodes" and also just for the mh-z node. both times no reports.

You said it use to work, what has changed? Did you do any upgrades?
Can you stop Node-RED and then in a terminal start it up and copy the log and paste it to a reply. I want to see if anything shows up in the log.

I didn't change anything, thats why I'm so clueless.
This is my first time using node red, how do i do that what you said?

What device are you running NR on?

How did you install NR?

If it is a pi, open a terminal and enter ‘node-red-stop’

I get this report. I know that the bme has an remote error I accidently damaged a wire.

But i don't know why MH-Z19 switches to passive mode.

Can you answer all my questions and show the full startup log and do a copy paste of it to a reply. Thanks

I Use node red on a RaspberryPi 4B.
I installed it as discribed here:

I also enabled autostart.

The full startup log is here.

I Hope this time I replied all of your questions.

What happens if you disable the bme280 nodes?

Everything stays the same.

did you start/stop nr and check that the bme error messages were gone?

You said that it was all working and then you accidently damaged a wire. Did this happen about the same time as the MH-Z19 node issue occurred?

Which node are you using to read the BME280? Is it using I2c and could there be an issue with I2c.

The BME has nothing to do with it, the mh-z went into timeout way before this thing with the wire's happened. I also disconnected the bme and rebooted everything but the mh-z is still in timeout or passive mode. I also disconnected the mh-z and changed wires but still n passive mode.
I use the node " node-red-contrib-bme280 : Bme280" for the bme.

Have you tried checking it outside node-red? Could the sensor be bad?

Yes i did that to. For CO2 measure it is one of the most reliable sensors.

I think you should open an issue on the nodes GitHub page.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.