Mi Home App /developer mode

#1

Hi,

This is only indirectly related to Node-RED. But is anyone here using Xiaomi Mijia Smart Home devices? I just bought the Mi Control Hub and cannot set it up to the developer mode necessary to connect it to Node-RED.

All the available Flows don't work anymore:

  • node-red-contrib-xiaomi-devices
  • xiaomi sensors to mqtt
  • node-red-contrib-xiaomi-smart-home etc.

There are guides available on Github and in the OpenHAB documentation. But the App changed - or the newest batch of the Xiaomi Hardware might not have a developer mode anymore.

Already posted this question in the OpenHAB forum - will forward the answer here, if I get a reply there.

1 Like
#2

Have you found this out yet ?
I have the same problem

#3

If nodes no longer work, you would be advised to open an issue on the nodes github page ( follow the github link from the nodes page on flows.nodered.org) which will notify the node's author

Having checked the github page for node-red-contrib-xiaomi-devices there is no issue opened

#4

Hi, I am more concerned in the enabling of the developer mode :slight_smile:
NodeRed is working ok for other stuff.
Its enabling the dev mode on my new Xiaomi Gateway I need help with, the app has changed and the option to enable dev mode is not there anymore

#5

Which firmware version has your Gateway?

1.4.1_159.0143 is fine for me.

#6

I have 3.3.10_114 on my control hub.

It’s not the firmware either, I want to enable developer mode so I can get the key to put into the Node red config.

#7

I understand what you need.

I'm using the Gateway 2 and did set the development mode on my iPhone with the Mi Home app v4.8.9 and was able to get the password 7D6...

What you mean by control hub?

#8

The control hub and gateway are the same thing from what I understand?
Unless I have the wrong device completely.

I’ll send some screenshots soon of my device.

#9

@ukmoose It is not a bug with the node-red-contrib-xiaomi-devices but with the Xiaomi HUB (either the Firmware or the Smartphone App accompanying it). In the newest version, you are no longer able to activate the Dev Mode - which means that the HUB does not show up as local device and cannot be used in Node-RED.

I posted this issue in several places - but did not get an answer yet. I did not raise an Github issue - as I don't know if the code is affected by it. If you already activated the DEV Mode, everything might just continue to work.

@zombiespawn I found a possible solution for this issue - unfortunately, this needs some additional Hardware to work, which I don't have yet. You can replace the Xiaomi Hub with a CC2531 USB sniffer that enables you to communicate directly via Zigbee with your Xiaomi sensors.

Links to the Hardware (and the Firmware that makes it work) can be found here on Github. And there are two (German) guides on how to use it in the FHEM Forum and here as a Youtube Tutorial.

#10

@mpxd FYI, I've just tried on my Mi Home app, I can access the hidden pages.

#11

@cflurin what is your App set to? Mainland China? I bought my Xiaomi Hardware in HongKong and have to set the App to HK to be able to connect (otherwise the HUB is not found on my network at all). I suspect that this is the issue. But I couldn't get my hand on a Xiaomi HUB with the Chinese Firmware installed.

#12

Region: Mainland China
Language: English

Select your Gateway and go to About
Tap on the About page (on the blank part) repeatedly.

#13

My Region is Hong Kong (setting it to China does not work - the Hub does not show up and so I cannot get to the Gateway About page). In this HK Mode the whole About page is missing. I tried other random spots to tap repeatedly but no luck.

#14

I have set the region to Mainland China at the first installation as far as I remember.
But this is the issue, the Dev mode only works in the Region Mainland China.

One option would be to reset the gateway and start again?

#15

Yes, you can decide during your first setup - i already went back to that and choose China. But the app no longer detects the gateway when set to the wrong locale. Seems to be a variable set inside the firmware of the gateway itself.

#16

As I said I would try to reset the gateway and setup again.

#17

Hello

I am using this

not only we can manage all the xiamoi zigbee sensors but also integrated them with other zigbee items, e.g. Ikea tradfri

give it a try

#18

That is the one I linked above. Just need to get the Hardware for it :thinking:

#19

Since one will be the coordinator, make sure to order some extra USB CC2531 so you may used the as router .

#20

Hi for this go to the mi home control app _ about _tab 4 times on plugin version _ it will enable developer mode.

1 Like