Missing info on the join

#1

So here is a weird one. When I drop a join component into a flow it's coming up as join.join and it's missing info. Any idea what's wrong here?

0 Likes

#2

I think there is something fundamental wrong somewhere, it is also missing the labels and such like in the properties window.
What OS/hardware are you using and versions of node.js and node-red?
Copy/Paste the node red log from starting node-red. In fact if you look at that first you may get an indication of the problem.

0 Likes

#3

So I’m running Node Red on top of Hass.io which is running on top of a PINE 64 running DietPi. The logs don’t tell me much. At least not to my unknowledgeable eye.

I uninstalled and reinstalled it just for the heck of it and it has the same problem.
[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 00-banner.sh: executing... 

-----------------------------------------------------------
 Hass.io Add-on: Node-RED v0.1.1

 Flow-based programming for the Internet of Things

 From: Community Hass.io Add-ons
 By: Franck Nijhof <frenck@addons.community>
-----------------------------------------------------------
[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing... 
Log level is set to INFO
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] 02-updates.sh: executing... 

INFO: You are running the latest version of this add-on
[cont-init.d] 02-updates.sh: exited 0.
[cont-init.d] 10-requirements.sh: executing... 
[cont-init.d] 10-requirements.sh: exited 0.
[cont-init.d] 11-warning.sh: executing... 
[cont-init.d] 11-warning.sh: exited 0.
[cont-init.d] 20-config.sh: executing... 
[cont-init.d] 20-config.sh: exited 0.
[cont-init.d] 80-system-packages.sh: executing... 
[cont-init.d] 80-system-packages.sh: exited 0.
[cont-init.d] 81-npm-packages.sh: executing... 
[cont-init.d] 81-npm-packages.sh: exited 0.
[cont-init.d] 82-user-scripts.sh: executing... 
[cont-init.d] 82-user-scripts.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.

> hassio-addon-node-red@1.0.0 start /opt
> node $NODE_OPTIONS node_modules/node-red/red.js "--settings" "/etc/node-red/config.js"

3 Jun 21:47:55 - [info] 

Welcome to Node-RED
===================

3 Jun 21:47:55 - [info] Node-RED version: v0.18.7
3 Jun 21:47:55 - [info] Node.js  version: v8.9.3
3 Jun 21:47:55 - [info] Linux 3.10.104-2-pine64-longsleep arm64 LE
3 Jun 21:48:02 - [info] Loading palette nodes
3 Jun 21:48:08 - [info] Dashboard version 2.9.4 started at /ui
3 Jun 21:48:12 - [warn] ------------------------------------------------------
3 Jun 21:48:12 - [warn] [node-red/rpi-gpio] Info : Ignoring Raspberry Pi specific node
3 Jun 21:48:12 - [warn] [node-red-contrib-join/join] 'join' already registered by module node-red
3 Jun 21:48:12 - [warn] ------------------------------------------------------
3 Jun 21:48:12 - [info] Settings file  : /etc/node-red/config.js
3 Jun 21:48:12 - [info] User directory : /config/node-red/
3 Jun 21:48:12 - [info] Server now running at http://127.0.0.1:1880/
3 Jun 21:48:12 - [info] Active project : Home_Automation
3 Jun 21:48:12 - [info] Flows file     : /config/node-red/projects/Home_Automation/flows.json
3 Jun 21:48:13 - [info] Starting flows
3 Jun 21:48:13 - [info] Started flows
0 Likes

#4

So either you have installed the extra node https://flows.nodered.org/node/node-red-contrib-join
or the Hass.io image you are using comes with it preinstalled.

This is conflicting with the join node that is part of the standard node-red

Try uninstalling node-red-contrib-join using manage palette in the menu and restart node-red and see if that fixes your problem

0 Likes

#5

So I gave that a shot, but when I click the disable button is doesn't really do anything. I get the loading bar and then it returns to the same screen. Unchanged. Interesting I do have a little warning of some kind there. Anyone know what that means? Yes I did restart it.

0 Likes

#6

Is this a node you’ve installed yourself or one that came with the image you’ve installed?

At this point, you may need to uninstall it from the command line - run npm remove node-red-contrib-join in the directory /config/node-red/

0 Likes

#7

Came with the image, I’ll try the command line in a moment here

0 Likes

#8

Ok - then this needs reporting back to whoever provided that image. contrib-join is not compatible with recent versions of Node-RED and should be removed.

0 Likes

#9

Man this little project just keeps giving me issues. This is what I get when I attempt this command. Any thoughts?

image

0 Likes

#10

if you have any of those join nodes on your flows delete them first then try to uninstall from palette and if is not working then stop node red and try from command line moving first to node-red directory and with command npm uninstall node-red-contrib-join and if not working as latest with sudo .

Regards

0 Likes

#11

Thanks David I gave that a shot but got the error above.

0 Likes

#12

Worst case, you can go into your config/node-red/node_modules directory and rm -r the node-red-contrib-join directory.

But npm should be installed somewhere as node 8.x comes with it, so something may have not installed fully. Will the Diet-pi software manager let you install it ?

0 Likes

#13

Good suggestion! I have since done that and everything is working in Node Red! Wonderful! I am having a little trouble installing node-red-contrib-home-assistant now but I’ll break that out into it’s own thread if it continues.

0 Likes

#14

Well, without npm you won’t be able to install any other new nodes, so you need to fix that)

0 Likes

#15

Author of the add-on here.

This is fixed and will be part of the upcoming release (which is expected today).

0 Likes