Why join node is not responding. Is it some kind of BUG?

I am using "join node" in my flow but its not working today.

Refresh your browser and check again

Check browser console for errors

Is this running on a PI?

Also try a different browser if possible.

  • Refreshed the browser
  • Tried with different browser.
  • Restarted the PC.
  • Running it on windows PC.
  • No such error is showing in browser console

Also, something is weird. when i pull the "join-node" from node palette, it gets converted to "join.join" node. I don't know why?(see attached image)

Tried it as per your suggestion but didn't worked.

The issue is Node-RED is not getting the translations - you are seeing the placeholders. Something is possibly corrupt or blocked (browser plugin/firewall/windows permission)

  1. Do any other nodes have this or similar issues?

  2. What language do you have set?

    1. what lang is shown in settings
    2. what lang is set in devtools->application->local storage->http://xx
  3. Can you open browser devtools, select the network tab, refresh the page, open the join node then check the network requests as below

First of all, thanks for giving your time and patience.

While i was trying on your methods, i also enabled verbose logging. On my CLI, i noticed what Can be the exact cause of problem. I am attesting the image here. So, i think this error is due to installation of another join node by the same name as "join node".

But why there is no option to remove it?(refer ? in attested image)

Because you have one or more in use on your flow.

Option 1 - remove from flow, deploy, refresh, uninstall
Option 2 - stop node-red, CD to your ~/.node-red dir, npm remove node-red-contrib-join, start node-red

For me second option worked. Now things are working good. Thankyou.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.