Mqtt broker does not receive data and no generate debug message


I was create flow for mqqt broker. Mqqt broker runing on win7 32bit machine. Mosquitto service is ok still runing and connected. But i can't recive an debug message or somone. What is my fault?

Best regards.

how you you configured the MQTT node?
what topic are you subscribing to?
what topic are you publishing data to?

i was configure that's it.

Have you checked that you can receive the messages using a different client?

or tried replacing the specific topic with a MQTT wildcard?

I've checked. I share result.

I tried replace topic with unique name but still same :frowning:

Try in NR: /# (wildcard) for the topic, then you subscribed to everything, handy for debugging.

no response :frowning:

/# and # are different in MQTT

i recive debug message "Invalid topic specified" then put /# in topic line.


I think problem around virtualization or network. It's tired me :frowning:


I tried , but still not working :frowning:

so if you think it’s a network issue you need to try a different MQTT client on the SAME machine as Node-RED and try to subscribe to a topic.

If you can’t then it’s not a Node-RED issue

I was try this way for solution

Send message with MQTT.fx from broker machine to NR. I saw recive message debug.

Ran broker application on the simulation mode. Watched the log windowd. Was get "no suitable 32-bit JRE was configured or found"

Install java broker machine

Problem solved.

Thanks all! for support.